The AES-NI implementation in OpenSSL ... CVE-2016-2107 CNNVD-201605-080

2.6 AV AC AU C I A
发布: 2016-05-03
修订: 2019-04-22

OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL 1.0.1t之前版本和1.0.2h之前1.0.2版本的AES-NI实现过程中存在安全漏洞,该漏洞源于程序在进行填充检查时没有考虑内存分配。远程攻击者可通过向AES CBC会话实施padding-oracle攻击利用该漏洞获取敏感的明文信息。(注:该漏洞源于CNNVD-201302-133补丁的不完全修复)

0%
当前有1条漏洞利用/PoC
当前有51条受影响产品信息