CVE-2013-4736
CVSS7.8
发布时间 :2014-02-10 13:15:10
修订时间 :2014-02-11 09:56:29
NMCOS    

[原文]Multiple integer overflows in the JPEG engine drivers in the MSM camera driver for the Linux kernel 3.x, as used in Qualcomm Innovation Center (QuIC) Android contributions for MSM devices and other products, allow attackers to cause a denial of service (system crash) via a large number of commands in an ioctl call, related to (1) camera_v1/gemini/msm_gemini_sync.c, (2) camera_v2/gemini/msm_gemini_sync.c, (3) camera_v2/jpeg_10/msm_jpeg_sync.c, (4) gemini/msm_gemini_sync.c, (5) jpeg_10/msm_jpeg_sync.c, and (6) mercury/msm_mercury_sync.c.


[CNNVD]Qualcomm Innovation Center Android for MSM 整数溢出漏洞(CNNVD-201402-101)

        

Android for MSM是一个Android的MSM项目,该项目的主要目的是建立一个包含高通MSM芯片组的Android平台。

Qualcomm Innovation Center (QuIC) Android contributions for MSM中使用的Linux kernel 3.x版本的MSM摄像机驱动中的JPEG引擎驱动中存在整数溢出漏洞。攻击者可借助octl调用中大量的命令利用该漏洞造成拒绝服务(系统崩溃)。

- CVSS (基础分值)

CVSS分值: 7.8 [严重(HIGH)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-189 [数值错误]

- CPE (受影响的平台与产品)

cpe:/o:codeaurora:android-msm:3.4.75
cpe:/o:codeaurora:android-msm:3.4.72
cpe:/o:codeaurora:android-msm:3.4.77
cpe:/o:codeaurora:android-msm:3.4.74
cpe:/o:codeaurora:android-msm:3.13
cpe:/o:codeaurora:android-msm:3.4.73
cpe:/o:codeaurora:android-msm:3.4.79
cpe:/o:codeaurora:android-msm:3.4.76
cpe:/o:codeaurora:android-msm:3.4.78
cpe:/o:codeaurora:android-msm:3.2.54
cpe:/o:codeaurora:android-msm:3.13:rc1
cpe:/o:codeaurora:android-msm:3.13:rc2
cpe:/o:codeaurora:android-msm:3.13:rc7
cpe:/o:codeaurora:android-msm:3.13:rc8
cpe:/o:codeaurora:android-msm:3.10.22
cpe:/o:codeaurora:android-msm:3.13:rc5
cpe:/o:codeaurora:android-msm:3.10.25
cpe:/o:codeaurora:android-msm:3.13:rc6
cpe:/o:codeaurora:android-msm:3.10.24
cpe:/o:codeaurora:android-msm:3.10.23
cpe:/o:codeaurora:android-msm:3.14:rc2
cpe:/o:codeaurora:android-msm:3.13:rc3
cpe:/o:codeaurora:android-msm:3.14:rc1
cpe:/o:codeaurora:android-msm:3.13:rc4
cpe:/o:codeaurora:android-msm:3.12.5
cpe:/o:codeaurora:android-msm:3.10.29
cpe:/o:codeaurora:android-msm:3.13.2
cpe:/o:codeaurora:android-msm:3.10.26
cpe:/o:codeaurora:android-msm:3.12.7
cpe:/o:codeaurora:android-msm:3.12.4
cpe:/o:codeaurora:android-msm:3.10.28
cpe:/o:codeaurora:android-msm:3.12.3
cpe:/o:codeaurora:android-msm:3.13.1
cpe:/o:codeaurora:android-msm:3.10.27
cpe:/o:codeaurora:android-msm:3.12.9
cpe:/o:codeaurora:android-msm:3.12.6
cpe:/o:codeaurora:android-msm:3.12.10
cpe:/o:codeaurora:android-msm:3.12.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4736
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4736
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201402-101
(官方数据源) CNNVD

- 其它链接及资源

https://www.codeaurora.org/projects/security-advisories/integer-overflow-and-signedness-issue-camera-jpeg-engines-cve-2013-4736
(VENDOR_ADVISORY)  CONFIRM  https://www.codeaurora.org/projects/security-advisories/integer-overflow-and-signedness-issue-camera-jpeg-engines-cve-2013-4736

- 漏洞信息

Qualcomm Innovation Center Android for MSM 整数溢出漏洞
高危 数字错误
2014-03-12 00:00:00 2014-03-12 00:00:00
远程  
        

Android for MSM是一个Android的MSM项目,该项目的主要目的是建立一个包含高通MSM芯片组的Android平台。

Qualcomm Innovation Center (QuIC) Android contributions for MSM中使用的Linux kernel 3.x版本的MSM摄像机驱动中的JPEG引擎驱动中存在整数溢出漏洞。攻击者可借助octl调用中大量的命令利用该漏洞造成拒绝服务(系统崩溃)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        https://www.codeaurora.org/projects/security-advisories/integer-overflow-and-signedness-issue-camera-jpeg-engines-cve-2013-4736

- 漏洞信息

96923
Multiple MSM JPEG Engines Unspecified Signedness Issue
Local Access Required Attack Type Unknown
Impact Unknown Patch / RCS
Exploit Unknown Vendor Verified

- 漏洞描述

Gemini JPEG encoder, Mercury JPEG decoder, and Jpeg1.0 common encoder/decoder contain an unspecified flaw related to incorrectly treating the number of hardware commands as signed. No further details have been provided.

- 时间线

2013-08-29 Unknow
Unknow 2013-08-29

- 解决方案

The vendor has released a patch to address this vulnerability. There are no known workarounds or upgrades to correct this issue. Check the vendor advisory, changelog, or solution in the references section for details.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Code Aurora Multiple Products MSM Camera Driver Multiple Integer Overflow Vulnerabilities
Boundary Condition Error 65567
Yes No
2014-02-11 12:00:00 2014-02-11 12:00:00
alephzain1@gmail.com

- 受影响的程序版本

- 漏洞讨论

Code Aurora MSM camera driver is prone to multiple integer-overflow vulnerabilities because it fails to perform adequate boundary checks on user-supplied data.

Attackers can exploit this issue to crash the application, denying service to legitimate users.

Code Aurora MSM camera driver 3.14 rc2 and prior are vulnerable.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references for more information.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站