CVE-2018-8012
CVSS5.0
发布时间 :2018-05-21 15:29:00
修订时间 :2018-06-27 08:08:15
NMPS    

[原文]No authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper before 3.4.10, and 3.5.0-alpha through 3.5.3-beta. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-306| CWE-285 []

- CPE (受影响的平台与产品)

cpe:/a:apache:zookeeper:-
cpe:/a:apache:zookeeper:3.4.0
cpe:/a:apache:zookeeper:3.4.1
cpe:/a:apache:zookeeper:3.4.2
cpe:/a:apache:zookeeper:3.4.3
cpe:/a:apache:zookeeper:3.4.4
cpe:/a:apache:zookeeper:3.4.5
cpe:/a:apache:zookeeper:3.4.6
cpe:/a:apache:zookeeper:3.4.7
cpe:/a:apache:zookeeper:3.4.8
cpe:/a:apache:zookeeper:3.4.9
cpe:/a:apache:zookeeper:3.5.0
cpe:/a:apache:zookeeper:3.5.0:alpha
cpe:/a:apache:zookeeper:3.5.1
cpe:/a:apache:zookeeper:3.5.2
cpe:/a:apache:zookeeper:3.5.3:beta
cpe:/o:debian:debian_linux:8.0
cpe:/o:debian:debian_linux:9.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-8012
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-8012
(官方数据源) NVD

- 其它链接及资源

http://www.securityfocus.com/bid/104253
(VENDOR_ADVISORY)  BID  104253
http://www.securitytracker.com/id/1040948
(VENDOR_ADVISORY)  SECTRACK  1040948
https://lists.apache.org/thread.html/c75147028c1c79bdebd4f8fa5db2b77da85de2b05ecc0d54d708b393@%3Cdev.zookeeper.apache.org%3E
(UNKNOWN)  MISC  https://lists.apache.org/thread.html/c75147028c1c79bdebd4f8fa5db2b77da85de2b05ecc0d54d708b393@%3Cdev.zookeeper.apache.org%3E
https://www.debian.org/security/2018/dsa-4214
(VENDOR_ADVISORY)  DEBIAN  DSA-4214

- 漏洞信息 (F148019)

Debian Security Advisory 4214-1 (PacketStormID:F148019)
2018-06-01 00:00:00
Debian  debian.org
advisory
linux,debian
CVE-2018-8012
[点击下载]

Debian Linux Security Advisory 4214-1 - It was discovered that Zookeeper, a service for maintaining configuration information, enforced no authentication/authorisation when a server attempts to join a Zookeeper quorum.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4214-1                   security@debian.org
https://www.debian.org/security/                       Moritz Muehlenhoff
June 01, 2018                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : zookeeper
CVE ID         : CVE-2018-8012

It was discovered that Zookeeper, a service for maintaining configuration
information, enforced no authentication/authorisation when a server
attempts to join a Zookeeper quorum.

This update backports authentication support. Additional configuration
steps are needed, please see
https://cwiki.apache.org/confluence/display/ZOOKEEPER/Server-Server+mutual+authentication
for additional information.

For the oldstable distribution (jessie), this problem has been fixed
in version 3.4.9-3+deb8u1.

For the stable distribution (stretch), this problem has been fixed in
version 3.4.9-3+deb9u1.

We recommend that you upgrade your zookeeper packages.

For the detailed security status of zookeeper please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/zookeeper

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEtuYvPRKsOElcDakFEMKTtsN8TjYFAlsRuPwACgkQEMKTtsN8
TjbnMw//fDJ4aC9z7/eDPlOHURPJPVshFSWcNeyTSnJR5lIESzpTJD5zEt7kHfGN
jU5akO5ZEiJn0A2z4XGzCATKKZveLqsJyXvGi5Y40XeaUIyrjz8xvCgsCwTyVoqx
d93laGfHQCF9r28nR16y8zX9+QtMfy1RtJKuQGy4veBv34tVoUkr1Fr7ibyGlSNg
ZKHeJjzDEYSrl1CGTAXqYUcF0vyPMgqwZpjHMBF28eRk+pCXIBMQKlKp1Q6k3Y9Z
GhglRu3X87ftnuthaRDSI4jnNBLxHWFhluALwRP6U+92B7cKKFzv5MuoWxBDrY8W
TngF7e1sCZCpFb2JWlXdQupxFwZgMJ4cztWgMeWK3WabgRjvFEXBaw/HJlEErTxN
kqHpPdDkt8XAUgpbezR63f8LZyPoD9H7/Na5WpygpOEJfCEYcDUAPxkV6FCW5ZH3
h5jtoLrOuN7EhRAvz/ykx/UmXmcou6t66toACQQrJFHvXy9gMQEJW9D6tUqcFUBA
xkWef+lRM65hGBD1HsZaIDI8f4D8wguYAthh76nLLe1VE0X2kzLn4/kzjQ8fw8/L
Lobz0IBe71YC5n090akWs+LPgUfEkWErn5ayJW4mII0hY4ktpiIFVMxhPRaNuwx1
CVwFg8YlEFc2TWhsWEA5ikH5R9JCpe6lLPOZXSGgg9DQ2h7N118=
=9SrO
-----END PGP SIGNATURE-----
    

- 漏洞信息

Apache ZooKeeper CVE-2018-8012 Security Bypass Vulnerability
Unknown 104253
Yes No
2018-05-21 12:00:00 2018-05-21 12:00:00
Földi Tamás and Eugene Koontz

- 受影响的程序版本

Apache ZooKeeper 3.3.5
Apache ZooKeeper 3.3
Apache ZooKeeper 3.5.3-beta
Apache ZooKeeper 3.5.0-alpha
Apache ZooKeeper 3.3
Apache ZooKeeper 1.0
,Apache ZooKeeper 3.4

- 不受影响的程序版本

Apache ZooKeeper 3.4

- 漏洞讨论

Apache ZooKeeper is prone to a security-bypass vulnerability.

Attackers can exploit this issue to bypass certain security restrictions to perform unauthorized actions. This may aid in further attacks.

Versions prior to Apache ZooKeeper 3.4.10 are vulnerable.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站