CVE-2018-8010
CVSS2.1
发布时间 :2018-05-21 15:29:00
修订时间 :2018-06-26 13:13:20
NMS    

[原文]This vulnerability in Apache Solr 6.0.0 to 6.6.3, 7.0.0 to 7.3.0 relates to an XML external entity expansion (XXE) in Solr config files (solrconfig.xml, schema.xml, managed-schema). In addition, Xinclude functionality provided in these config files is also affected in a similar way. The vulnerability can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network. Users are advised to upgrade to either Solr 6.6.4 or Solr 7.3.1 releases both of which address the vulnerability. Once upgrade is complete, no other steps are required. Those releases only allow external entities and Xincludes that refer to local files / zookeeper resources below the Solr instance directory (using Solr's ResourceLoader); usage of absolute URLs is denied. Keep in mind, that external entities and XInclude are explicitly supported to better structure config files in large installations. Before Solr 6 this was no problem, as config files were not accessible through the APIs.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-611 [XML外部实体引用的不恰当限制(XXE)]

- CPE (受影响的平台与产品)

cpe:/a:apache:solr:6.0.0
cpe:/a:apache:solr:6.0.1
cpe:/a:apache:solr:6.1.0
cpe:/a:apache:solr:6.2.0
cpe:/a:apache:solr:6.2.1
cpe:/a:apache:solr:6.3.0
cpe:/a:apache:solr:6.4.0
cpe:/a:apache:solr:6.4.1
cpe:/a:apache:solr:6.4.2
cpe:/a:apache:solr:6.5.0
cpe:/a:apache:solr:6.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-8010
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-8010
(官方数据源) NVD

- 其它链接及资源

http://www.securityfocus.com/bid/104239
(VENDOR_ADVISORY)  BID  104239
https://mail-archives.apache.org/mod_mbox/www-announce/201805.mbox/%3C08a801d3f0f9%24df46d300%249dd47900%24%40apache.org%3E
(VENDOR_ADVISORY)  MISC  https://mail-archives.apache.org/mod_mbox/www-announce/201805.mbox/%3C08a801d3f0f9%24df46d300%249dd47900%24%40apache.org%3E

- 漏洞信息

Apache Solr CVE-2018-8010 XML External Entity Multiple Information Disclosure Vulnerabilities
Design Error 104239
Yes No
2018-05-21 12:00:00 2018-05-21 12:00:00
Ananthesh and Ishan Chattopadhyaya.

- 受影响的程序版本

Apache Solr 7.2.1
Apache Solr 7.0
Apache Solr 6.6.3
Apache Solr 6.6.2
Apache Solr 6.6.1
Apache Solr 6.6
Apache Solr 6.5.1
Apache Solr 6.5
Apache Solr 6.4
Apache Solr 6.3
Apache Solr 6.2
Apache Solr 7.3
Apache Solr 6.6
Apache Solr 6.3
Apache Solr 6.0
,Apache Solr 7.3.1
Apache Solr 6.6.4
Apache Solr 7.4

- 不受影响的程序版本

Apache Solr 7.3.1
Apache Solr 6.6.4
Apache Solr 7.4

- 漏洞讨论

Apache Solr is prone to multiple information-disclosure vulnerabilities.

An attacker can exploit these issues to gain access to sensitive information that may lead to further attacks.

Apache Solr versions 6.0.0 through 6.6.3, and 7.0.0 through 7.3.0 are vulnerable.

- 漏洞利用

An attacker can exploit these issues using readily available tools.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站