CVE-2018-8008
CVSS5.8
发布时间 :2018-06-05 15:29:00
修订时间 :2018-06-20 13:43:09
NMS    

[原文]Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 5.8 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

cpe:/a:pivotal_software:spring_integration_zip:1.0.6
cpe:/a:pivotal_software:spring_integration_zip:1.1.2
cpe:/a:pivotal_software:spring_integration_zip:1.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-8008
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-8008
(官方数据源) NVD

- 其它链接及资源

http://www.securityfocus.com/bid/104418
(VENDOR_ADVISORY)  BID  104418
https://lists.apache.org/thread.html/613b2fca8bcd0a3b12c0b763ea8f7cf62e422e9f79fce6cfa5b08a58@%3Cdev.storm.apache.org%3E
(VENDOR_ADVISORY)  CONFIRM  https://lists.apache.org/thread.html/613b2fca8bcd0a3b12c0b763ea8f7cf62e422e9f79fce6cfa5b08a58@%3Cdev.storm.apache.org%3E

- 漏洞信息

Apache Storm CVE-2018-8008 Arbitrary File Write Vulnerability
Failure to Handle Exceptional Conditions 104418
Yes No
2018-06-05 12:00:00 2018-06-05 12:00:00
Snyk Security Research Team

- 受影响的程序版本

Apache Storm 1.2.1
Apache Storm 1.2
Apache Storm 1.1.2
Apache Storm 1.1.1
Apache Storm 1.1
Apache Storm 1.0.6
Apache Storm 1.0.4
Apache Storm 1.0.3
Apache Storm 1.0.2
Apache Storm 1.0.1
Apache Storm 1.0
,Apache Storm 1.2.2
Apache Storm 1.1.3

- 不受影响的程序版本

Apache Storm 1.2.2
Apache Storm 1.1.3

- 漏洞讨论

Apache Storm is prone to a security vulnerability that allows remote attackers to write arbitrary files.

Successful exploits may allow an attacker to write arbitrary files to the affected system. This may aid in further attacks.

Storm 1.0.6 and prior, 1.2.1 and prior, and 1.1.2 and prior are vulnerable.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站