CVE-2018-8007
CVSSN/A
发布时间 :2018-07-11 09:29:00
修订时间 :2018-07-11 09:29:00
NMS    

[原文]Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS暂不可用

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-8007
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-8007
(官方数据源) NVD

- 其它链接及资源

http://mail-archives.apache.org/mod_mbox/couchdb-announce/201807.mbox/%3c1439409216.6221.1531246856676.JavaMail.Joan@RITA%3e
(UNKNOWN)  MLIST  [couchdb-announce] 20180710 Apache CouchDB 2.1.2 released
http://mail-archives.apache.org/mod_mbox/couchdb-announce/201807.mbox/%3C1699016538.6219.1531246785603.JavaMail.Joan%40RITA%3E
(UNKNOWN)  MLIST  [couchdb-announce] 20180710 Apache CouchDB 1.7.2 released
https://blog.couchdb.org/2018/07/10/cve-2018-8007/
(UNKNOWN)  CONFIRM  https://blog.couchdb.org/2018/07/10/cve-2018-8007/

- 漏洞信息

Apache CouchDB CVE-2018-8007 Remote Privilege Escalation Vulnerability
Input Validation Error 104741
Yes No
2018-07-10 12:00:00 2018-07-10 12:00:00
Francesco Oddo of MDSec Labs.

- 受影响的程序版本

Apache CouchDB 2.1.1
Apache CouchDB 2.1
Apache CouchDB 2.0
Apache CouchDB 1.7
Apache CouchDB 1.6
Apache CouchDB 1.5
Apache CouchDB 1.2.1
Apache CouchDB 1.2
Apache CouchDB 1.1.2
Apache CouchDB 1.1.1
Apache CouchDB 1.0.4
Apache CouchDB 1.0.3
Apache CouchDB 1.0.2
Apache CouchDB 1.0.1
Apache CouchDB 1.0
Apache CouchDB 2.0.0.1
Apache CouchDB 2.0
Apache CouchDB 1.1.0
,Apache CouchDB 2.1.2
Apache CouchDB 1.7.2

- 不受影响的程序版本

Apache CouchDB 2.1.2
Apache CouchDB 1.7.2

- 漏洞讨论

Apache CouchDB is prone to a remote privilege-escalation vulnerability.

A remote attacker can exploit this issue to execute arbitrary code with elevated privileges. Successful exploits may aid in further attacks.

Apache CouchDB versions prior to 1.7.2 and 2.1.2 are vulnerable.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站