CVE-2018-8003
CVSS5.0
发布时间 :2018-05-03 19:29:00
修订时间 :2018-06-13 11:09:47
NMS    

[原文]Apache Ambari, versions 1.4.0 to 2.6.1, is susceptible to a directory traversal attack allowing an unauthenticated user to craft an HTTP request which provides read-only access to any file on the filesystem of the host the Ambari Server runs on that is accessible by the user the Ambari Server is running as. Direct network access to the Ambari Server is required to issue this request, and those Ambari Servers that are protected behind a firewall, or in a restricted network zone are at less risk of being affected by this issue.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

cpe:/a:apache:ambari:2.1.2
cpe:/a:apache:ambari:2.2.0
cpe:/a:apache:ambari:2.2.1
cpe:/a:apache:ambari:2.2.2
cpe:/a:apache:ambari:2.2.2:rc0
cpe:/a:apache:ambari:2.2.2:rc1
cpe:/a:apache:ambari:2.4.0
cpe:/a:apache:ambari:2.4.0:rc0
cpe:/a:apache:ambari:2.4.1
cpe:/a:apache:ambari:2.4.1:rc0
cpe:/a:apache:ambari:2.4.1:rc1
cpe:/a:apache:ambari:2.4.2:rc0
cpe:/a:apache:ambari:2.4.2:rc1
cpe:/a:apache:ambari:2.5.0:rc0
cpe:/a:apache:ambari:2.5.0:rc1
cpe:/a:apache:ambari:2.5.0:rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-8003
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-8003
(官方数据源) NVD

- 其它链接及资源

http://www.securityfocus.com/bid/104161
(VENDOR_ADVISORY)  BID  104161
https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Vulnerabilities#AmbariVulnerabilities-CVE-2018-8003
(VENDOR_ADVISORY)  CONFIRM  https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Vulnerabilities#AmbariVulnerabilities-CVE-2018-8003

- 漏洞信息

Apache Ambari CVE-2018-8003 Directory Traversal Vulnerability
Input Validation Error 104161
Yes No
2018-05-03 12:00:00 2018-05-03 12:00:00
Krzysztof Przybylski from STM Solutions

- 受影响的程序版本

Apache Ambari 2.6.1
Apache Ambari 2.6
Apache Ambari 2.5.1
Apache Ambari 2.5
Apache Ambari 2.1.1
Apache Ambari 2.1
Apache Ambari 2.0.2
Apache Ambari 2.0.1
Apache Ambari 2.0
Apache Ambari 1.5.1
Apache Ambari 1.5
Apache Ambari 1.4.4
Apache Ambari 1.4.3
Apache Ambari 1.4.2
Apache Ambari 1.4.1
Apache Ambari 1.4
Apache Ambari 2.4.3
Apache Ambari 2.4.2
Apache Ambari 2.4.1
Apache Ambari 2.4.0
Apache Ambari 2.2.2
Apache Ambari 2.2.1
Apache Ambari 2.2.0
Apache Ambari 2.1.2
Apache Ambari 1.7.0
,Apache Ambari 2.6.2

- 不受影响的程序版本

Apache Ambari 2.6.2

- 漏洞讨论

Apache Ambari is prone to a directory-traversal vulnerability because the application fails to sufficiently sanitize user-supplied input.

Remote attackers may use a specially crafted request with directory-traversal sequences ('../') to retrieve arbitrary files from the affected system in the context of the application. Information obtained could aid in further attacks.

Ambari 1.4.0 through Ambari 2.6.1 are vulnerable.

- 漏洞利用

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站