CVE-2018-7858
CVSS2.1
发布时间 :2018-03-12 17:29:01
修订时间 :2018-05-17 21:29:05
NMPS    

[原文]Quick Emulator (aka QEMU), when built with the Cirrus CLGD 54xx VGA Emulator support, allows local guest OS privileged users to cause a denial of service (out-of-bounds access and QEMU process crash) by leveraging incorrect region calculation when updating VGA display.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-125 [跨界内存读]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7858
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-7858
(官方数据源) NVD

- 其它链接及资源

http://www.openwall.com/lists/oss-security/2018/03/09/1
(VENDOR_ADVISORY)  MLIST  [oss-security] 20180309 CVE-2018-7858 Qemu: cirrus: OOB access when updating vga display
http://www.securityfocus.com/bid/103350
(VENDOR_ADVISORY)  BID  103350
https://access.redhat.com/errata/RHSA-2018:1369
(UNKNOWN)  REDHAT  RHSA-2018:1369
https://access.redhat.com/errata/RHSA-2018:1416
(UNKNOWN)  REDHAT  RHSA-2018:1416
https://bugzilla.redhat.com/show_bug.cgi?id=1553402
(VENDOR_ADVISORY)  CONFIRM  https://bugzilla.redhat.com/show_bug.cgi?id=1553402
https://lists.nongnu.org/archive/html/qemu-devel/2018-03/msg02174.html
(PATCH)  MLIST  [qemu-devel] 20180308 [PATCH] vga: fix region calculation
https://usn.ubuntu.com/3649-1/
(UNKNOWN)  UBUNTU  USN-3649-1

- 漏洞信息 (F147580)

Red Hat Security Advisory 2018-1369-01 (PacketStormID:F147580)
2018-05-10 00:00:00
Red Hat  
advisory
linux,redhat
CVE-2018-7550,CVE-2018-7858
[点击下载]

Red Hat Security Advisory 2018-1369-01 - KVM is a full virtualization solution for Linux on a variety of architectures. The qemu-kvm-rhev packages provide the user-space component for running virtual machines that use KVM in environments managed by Red Hat products. Issues addressed include out-of-bounds access.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: qemu-kvm-rhev security and bug fix update
Advisory ID:       RHSA-2018:1369-01
Product:           Red Hat Virtualization
Advisory URL:      https://access.redhat.com/errata/RHSA-2018:1369
Issue date:        2018-05-10
CVE Names:         CVE-2018-7550 CVE-2018-7858 
=====================================================================

1. Summary:

An update for qemu-kvm-rhev is now available for Red Hat Virtualization 4
for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts - ppc64le, x86_64

3. Description:

KVM (Kernel-based Virtual Machine) is a full virtualization solution for
Linux on a variety of architectures. The qemu-kvm-rhev packages provide the
user-space component for running virtual machines that use KVM in
environments managed by Red Hat products.

Security Fix(es):

* QEMU: i386: multiboot OOB access while loading kernel image
(CVE-2018-7550)

* QEMU: cirrus: OOB access when updating VGA display (CVE-2018-7858)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

Red Hat would like to thank Cyrille Chatras (Orange.com) and CERT-CC
(Orange.com) for reporting CVE-2018-7550 and Ross Lagerwall (Citrix.com)
for reporting CVE-2018-7858.

Bug Fix(es):

* In certain Red Hat Virtualization (RHV) guest configurations, virtual
pass-through devices could not be removed properly. A reference count leak
in the QEMU emulator has been removed, and the affected devices are now
removed reliably. (BZ#1555213)

* Previously, a raw disk image that was using the "--preallocation=full"
option in some cases could not be resized. This problem has been fixed and
no longer occurs. (BZ#1566587)

* Due to race conditions in the virtio-blk and virtio-scsi services, the
QEMU emulator sometimes terminated unexpectedly when shutting down. The
race conditions have been removed, and QEMU now exits gracefully.
(BZ#1566586)

* Prior to this update, deleting guest snapshots using the RHV GUI in some
cases failed due to an incorrect image-seeking algorithm. This update fixes
the underlying code, and guest snapshots in RHV can now be deleted
successfully. (BZ#1566369)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing this update, shut down all running virtual machines. Once
all virtual machines have shut down, start them again for this update to
take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

1549798 - CVE-2018-7550 QEMU: i386: multiboot OOB access while loading kernel image
1553402 - CVE-2018-7858 QEMU: cirrus: OOB access when updating VGA display
1555213 - [Q35] "DEVICE_DELETED" event didn't return after delete the second passthrough vf device [rhel-7.5.z]
1566369 - qemu-img commit fails with "block/file-posix.c:1774: find_allocation: Assertion `offs >= start' failed" [rhel-7.5.z]
1566586 - Occurred core dump with multi-object when quitted qemu during doing IO [rhel-7.5.z]
1566587 - Unable to resize image with preallocation=full mode [rhel-7.5.z]

6. Package List:

Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts:

Source:
qemu-kvm-rhev-2.10.0-21.el7_5.2.src.rpm

ppc64le:
qemu-img-rhev-2.10.0-21.el7_5.2.ppc64le.rpm
qemu-kvm-common-rhev-2.10.0-21.el7_5.2.ppc64le.rpm
qemu-kvm-rhev-2.10.0-21.el7_5.2.ppc64le.rpm
qemu-kvm-rhev-debuginfo-2.10.0-21.el7_5.2.ppc64le.rpm
qemu-kvm-tools-rhev-2.10.0-21.el7_5.2.ppc64le.rpm

x86_64:
qemu-img-rhev-2.10.0-21.el7_5.2.x86_64.rpm
qemu-kvm-common-rhev-2.10.0-21.el7_5.2.x86_64.rpm
qemu-kvm-rhev-2.10.0-21.el7_5.2.x86_64.rpm
qemu-kvm-rhev-debuginfo-2.10.0-21.el7_5.2.x86_64.rpm
qemu-kvm-tools-rhev-2.10.0-21.el7_5.2.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-7550
https://access.redhat.com/security/cve/CVE-2018-7858
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFa9G21XlSAg2UNWIIRAmgOAJ4r5Lw6uXQkppwAeKOvFFjnow4GywCgkDPa
q3JWDrWjmFbMgNQCwF4VK/M=
=CrX9
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
    

- 漏洞信息 (F147620)

Red Hat Security Advisory 2018-1416-01 (PacketStormID:F147620)
2018-05-15 00:00:00
Red Hat  
advisory,kernel
linux,redhat
CVE-2018-7858
[点击下载]

Red Hat Security Advisory 2018-1416-01 - Kernel-based Virtual Machine is a full virtualization solution for Linux on a variety of architectures. The qemu-kvm packages provide the user-space component for running virtual machines that use KVM. Issues addressed include an out of bounds access vulnerability.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: qemu-kvm security update
Advisory ID:       RHSA-2018:1416-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2018:1416
Issue date:        2018-05-14
CVE Names:         CVE-2018-7858 
=====================================================================

1. Summary:

An update for qemu-kvm is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode Optional (v. 7) - x86_64
Red Hat Enterprise Linux Server (v. 7) - x86_64
Red Hat Enterprise Linux Workstation (v. 7) - x86_64

3. Description:

Kernel-based Virtual Machine (KVM) is a full virtualization solution for
Linux on a variety of architectures. The qemu-kvm packages provide the
user-space component for running virtual machines that use KVM.

Security Fix(es):

* QEMU: cirrus: OOB access when updating VGA display (CVE-2018-7858)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

Red Hat would like to thank Ross Lagerwall (Citrix.com) for reporting this
issue.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing this update, shut down all running virtual machines. Once
all virtual machines have shut down, start them again for this update to
take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

1553402 - CVE-2018-7858 QEMU: cirrus: OOB access when updating VGA display

6. Package List:

Red Hat Enterprise Linux Client (v. 7):

Source:
qemu-kvm-1.5.3-156.el7_5.1.src.rpm

x86_64:
qemu-img-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-common-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-debuginfo-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-tools-1.5.3-156.el7_5.1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional (v. 7):

Source:
qemu-kvm-1.5.3-156.el7_5.1.src.rpm

x86_64:
qemu-img-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-common-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-debuginfo-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-tools-1.5.3-156.el7_5.1.x86_64.rpm

Red Hat Enterprise Linux Server (v. 7):

Source:
qemu-kvm-1.5.3-156.el7_5.1.src.rpm

x86_64:
qemu-img-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-common-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-debuginfo-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-tools-1.5.3-156.el7_5.1.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 7):

Source:
qemu-kvm-1.5.3-156.el7_5.1.src.rpm

x86_64:
qemu-img-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-common-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-debuginfo-1.5.3-156.el7_5.1.x86_64.rpm
qemu-kvm-tools-1.5.3-156.el7_5.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-7858
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBWvsEMdzjgjWX9erEAQiOVA/8CcAOukK37dOODZYLFQdfkkLKFy9htlTJ
5U/ndI1n8Tlk4+dv/W8fNH8TdO85uPGHMdI2v/wqRuPCoqAc6vBTZERBFAJOuz9l
p/oYHWI7VnrpJIKcZdvWm8MtleJAXGLKKtocamLRHC+/QLD7nyP8Sf/vNgIQLgZo
dFsBrH+AMO7jYkFqDU3z9FdcUB4nmloMjpFqDl7J6BdUS1b/75xbIm8MId0PIgiw
o0OhEl4qdu4S+LRXbZtPXkdrnbyFd26oIln88vme9y5i0c9jjtOpl/IJTH/yMOD2
uu+Qb15WwSUGaN3SDAhkUo9rAk4wkPd7M9Tcmi69+Pecra7L4oWew3jDOXN9w+1H
URpTEMCU80Klarg0nJADLKppE/QFczRMsyaCy4Y+jzwBj/xHIaMgCuzyRXJLCmqH
BeEL31wiMk66boCE6r8YK8KAQ0NHgb0Aw+SJaZF2fPLL3jSLyRqIyQCG+T+5bv0x
wmiPMae36LmrYB+c4OjqeQtTWECMM7yGLQ0eMMvSLzM06+dVHfPJk6aHbjeRs5bN
K5C6mz3KrGTXuTSxNGv+t7QzdHp0xGdqSD9UkSagkfj3h8gm3TBVPED5nH/M/a3F
sThSPczwF4zocUReHCM6p5igbgcdlwXRcA8zE67uKCVdIRZVjCLyOGPrmmi05s84
ZeAxzdcPex4=
=CG8y
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
    

- 漏洞信息 (F147661)

Ubuntu Security Notice USN-3649-1 (PacketStormID:F147661)
2018-05-16 00:00:00
Ubuntu  security.ubuntu.com
advisory,denial of service,arbitrary
linux,ubuntu
CVE-2017-16845,CVE-2018-7550,CVE-2018-7858
[点击下载]

Ubuntu Security Notice 3649-1 - Cyrille Chatras discovered that QEMU incorrectly handled certain PS2 values during migration. An attacker could possibly use this issue to cause QEMU to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. Cyrille Chatras discovered that QEMU incorrectly handled multiboot. An attacker could use this issue to cause QEMU to crash, resulting in a denial of service, or possibly execute arbitrary code on the host. In the default installation, when QEMU is used with libvirt, attackers would be isolated by the libvirt AppArmor profile. Various other issues were also addressed.

==========================================================================
Ubuntu Security Notice USN-3649-1
May 16, 2018

qemu vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in QEMU.

Software Description:
- qemu: Machine emulator and virtualizer

Details:

Cyrille Chatras discovered that QEMU incorrectly handled certain PS2 values
during migration. An attacker could possibly use this issue to cause QEMU
to crash, resulting in a denial of service, or possibly execute arbitrary
code. This issue only affected Ubuntu 18.04 LTS. (CVE-2017-16845)

Cyrille Chatras discovered that QEMU incorrectly handled multiboot. An
attacker could use this issue to cause QEMU to crash, resulting in a denial
of service, or possibly execute arbitrary code on the host. In the default
installation, when QEMU is used with libvirt, attackers would be isolated
by the libvirt AppArmor profile. (CVE-2018-7550)

Ross Lagerwall discovered that QEMU incorrectly handled the Cirrus VGA
device. A privileged attacker inside the guest could use this issue to
cause QEMU to crash, resulting in a denial of service. This issue only
affected Ubuntu 17.10 and Ubuntu 18.04 LTS. (CVE-2018-7858)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
  qemu-system                     1:2.11+dfsg-1ubuntu7.1
  qemu-system-arm                 1:2.11+dfsg-1ubuntu7.1
  qemu-system-mips                1:2.11+dfsg-1ubuntu7.1
  qemu-system-ppc                 1:2.11+dfsg-1ubuntu7.1
  qemu-system-s390x               1:2.11+dfsg-1ubuntu7.1
  qemu-system-sparc               1:2.11+dfsg-1ubuntu7.1
  qemu-system-x86                 1:2.11+dfsg-1ubuntu7.1

Ubuntu 17.10:
  qemu-system                     1:2.10+dfsg-0ubuntu3.6
  qemu-system-aarch64             1:2.10+dfsg-0ubuntu3.6
  qemu-system-arm                 1:2.10+dfsg-0ubuntu3.6
  qemu-system-mips                1:2.10+dfsg-0ubuntu3.6
  qemu-system-ppc                 1:2.10+dfsg-0ubuntu3.6
  qemu-system-s390x               1:2.10+dfsg-0ubuntu3.6
  qemu-system-sparc               1:2.10+dfsg-0ubuntu3.6
  qemu-system-x86                 1:2.10+dfsg-0ubuntu3.6

Ubuntu 16.04 LTS:
  qemu-system                     1:2.5+dfsg-5ubuntu10.28
  qemu-system-aarch64             1:2.5+dfsg-5ubuntu10.28
  qemu-system-arm                 1:2.5+dfsg-5ubuntu10.28
  qemu-system-mips                1:2.5+dfsg-5ubuntu10.28
  qemu-system-ppc                 1:2.5+dfsg-5ubuntu10.28
  qemu-system-s390x               1:2.5+dfsg-5ubuntu10.28
  qemu-system-sparc               1:2.5+dfsg-5ubuntu10.28
  qemu-system-x86                 1:2.5+dfsg-5ubuntu10.28

Ubuntu 14.04 LTS:
  qemu-system                     2.0.0+dfsg-2ubuntu1.41
  qemu-system-aarch64             2.0.0+dfsg-2ubuntu1.41
  qemu-system-arm                 2.0.0+dfsg-2ubuntu1.41
  qemu-system-mips                2.0.0+dfsg-2ubuntu1.41
  qemu-system-ppc                 2.0.0+dfsg-2ubuntu1.41
  qemu-system-sparc               2.0.0+dfsg-2ubuntu1.41
  qemu-system-x86                 2.0.0+dfsg-2ubuntu1.41

After a standard system update you need to restart all QEMU virtual
machines to make all the necessary changes.

References:
  https://usn.ubuntu.com/usn/usn-3649-1
  CVE-2017-16845, CVE-2018-7550, CVE-2018-7858

Package Information:
  https://launchpad.net/ubuntu/+source/qemu/1:2.11+dfsg-1ubuntu7.1
  https://launchpad.net/ubuntu/+source/qemu/1:2.10+dfsg-0ubuntu3.6
  https://launchpad.net/ubuntu/+source/qemu/1:2.5+dfsg-5ubuntu10.28
  https://launchpad.net/ubuntu/+source/qemu/2.0.0+dfsg-2ubuntu1.41

    

- 漏洞信息

QEMU CVE-2018-7858 Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 103350
Yes No
2018-03-08 12:00:00 2018-03-08 12:00:00
Ross Lagerwall of Citrix.

- 受影响的程序版本

Redhat OpenStack Platform 9.0
Redhat OpenStack Platform 8.0 (Liberty)
Redhat OpenStack Platform 8.0
Redhat OpenStack Platform 12
Redhat OpenStack Platform 11
Redhat OpenStack Platform 10
Redhat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7
Redhat Enterprise Linux 7
Redhat Enterprise Linux 6
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
QEMU QEMU 0

- 漏洞讨论

- 漏洞利用

- 解决方案

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站