CVE-2018-1309
CVSS7.5
发布时间 :2018-05-23 10:29:00
修订时间 :2018-06-27 08:07:51
NMS    

[原文]Apache NiFi External XML Entity issue in SplitXML processor. Malicious XML content could cause information disclosure or remote code execution. The fix to disable external general entity parsing and disallow doctype declarations was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-611 [XML外部实体引用的不恰当限制(XXE)]

- CPE (受影响的平台与产品)

cpe:/a:apache:nifi:0.2.1
cpe:/a:apache:nifi:0.3.0
cpe:/a:apache:nifi:0.4.0
cpe:/a:apache:nifi:0.4.1
cpe:/a:apache:nifi:0.5.0
cpe:/a:apache:nifi:0.5.1
cpe:/a:apache:nifi:0.6.0
cpe:/a:apache:nifi:0.6.1
cpe:/a:apache:nifi:0.7.2
cpe:/a:apache:nifi:0.7.4
cpe:/a:apache:nifi:1.4.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1309
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-1309
(官方数据源) NVD

- 其它链接及资源

https://nifi.apache.org/security.html#CVE-2018-1309
(VENDOR_ADVISORY)  CONFIRM  https://nifi.apache.org/security.html#CVE-2018-1309

- 漏洞信息

Apache NiFi XML External Entity Injection and Denial of Service Vulnerability
Input Validation Error 104313
Yes No
2018-04-08 12:00:00 2018-04-08 12:00:00
Unknown

- 受影响的程序版本

Apache Nifi 1.5
Apache Nifi 1.4
Apache Nifi 1.3
Apache Nifi 1.2
Apache Nifi 1.1.2
Apache Nifi 1.1.1
Apache Nifi 1.1
Apache Nifi 1.0.1
Apache Nifi 1.0
Apache Nifi 0.7.4
Apache Nifi 0.7.3
Apache Nifi 0.7.2
Apache Nifi 0.7.1
Apache Nifi 0.7
Apache Nifi 0.1
,Apache Nifi 1.6

- 不受影响的程序版本

Apache Nifi 1.6

- 漏洞讨论

Apache NiFi is prone to an XML External Entity injection vulnerability and a denial-of-service vulnerability.

Attackers can exploit this issue to gain access to sensitive information, execute arbitrary-code or cause denial-of-service conditions.

NiFi 0.1.0 through 1.5.0 are vulnerable.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站