发布时间 :2018-01-09 22:29:00
修订时间 :2018-02-02 11:58:14

[原文]When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster may execute OQL queries that allow read and write access to objects within unauthorized regions. In addition a user could invoke methods that allow remote code execution.



- CVSS (基础分值)

CVSS分值: 6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]

- CWE (弱点类目)

CWE-200 [信息暴露]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD

- 其它链接及资源
(VENDOR_ADVISORY)  MLIST  [user] 20180109 [SECURITY] CVE-2017-9795 Apache Geode OQL method invocation vulnerability

- 漏洞信息

Apache Geode CVE-2017-9795 Remote Code Execution Vulnerability
Input Validation Error 102488
Yes No
2018-01-09 12:00:00 2018-01-09 12:00:00
Dan Smith from Pivotal.

- 受影响的程序版本

Apache Geode 1.2.1
Apache Geode 1.2
Apache Geode 1.1.1
Apache Geode 1.1
Apache Geode 1.0
,Apache Geode 1.3

- 不受影响的程序版本

Apache Geode 1.3

- 漏洞讨论

Apache Geode is prone to a remote code-execution vulnerability.

Attackers can exploit this issue to execute arbitrary code in the context of the user running the affected applications. Failed exploit attempts will likely cause a denial-of-service condition.

Apache Geode 1.0.0 through 1.2.1 is vulnerable; other versions may also be affected.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考