CVE-2017-3165
CVSS3.5
发布时间 :2017-09-13 12:29:00
修订时间 :2017-09-27 13:55:33
NMS    

[原文]In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site scripting where one authenticated user can cause scripts to run in the browser of another user authorized to access the first user's resources. This is due to improper escaping of server-side content. There is known to be a proof-of-concept exploit using this vulnerability.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 3.5 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: SINGLE_INSTANCE [--]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3165
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-3165
(官方数据源) NVD

- 其它链接及资源

http://www.securityfocus.com/bid/96228
(VENDOR_ADVISORY)  BID  96228
https://brooklyn.apache.org/community/security/CVE-2017-3165.html
(VENDOR_ADVISORY)  CONFIRM  https://brooklyn.apache.org/community/security/CVE-2017-3165.html
https://lists.apache.org/thread.html/5aa6b7583edbfc1f5653607003204326d9e27ef65e8af356c798b21c@%3Cdev.brooklyn.apache.org%3E
(VENDOR_ADVISORY)  MLIST  [dev] 20170210 [SECURITY] CVE-2017-3165: Cross-site vulnerabilities in Apache Brooklyn

- 漏洞信息

Apache Brooklyn Cross Site Request Forgery and Multiple Cross Site Scripting Vulnerabilities
Input Validation Error 96228
Yes No
2017-02-15 12:00:00 2017-02-22 11:03:00
Toshitsugu Yoneyama of Mitsui Bussan Secure Directions, Inc.

- 受影响的程序版本

Apache Brooklyn 0.9.0
,Apache Brooklyn 0.10.0

- 不受影响的程序版本

Apache Brooklyn 0.10.0

- 漏洞讨论

Apache Brooklyn is prone to a cross-site request-forgery vulnerability and multiple cross-site scripting vulnerabilities.

An attacker may exploit these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, steal cookie-based authentication credentials, or perform unauthorized actions. Other attacks may also be possible.

Apache Brooklyn 0.9.0 and prior versions are vulnerable.

- 漏洞利用

An attacker must trick an unsuspecting victim into following a malicious URI to exploit these issues.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站