发布时间 :2017-09-13 12:29:00
修订时间 :2017-09-27 13:55:33

[原文]In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site scripting where one authenticated user can cause scripts to run in the browser of another user authorized to access the first user's resources. This is due to improper escaping of server-side content. There is known to be a proof-of-concept exploit using this vulnerability.



- CVSS (基础分值)

CVSS分值: 3.5 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD

- 其它链接及资源
(VENDOR_ADVISORY)  MLIST  [dev] 20170210 [SECURITY] CVE-2017-3165: Cross-site vulnerabilities in Apache Brooklyn

- 漏洞信息

Apache Brooklyn Cross Site Request Forgery and Multiple Cross Site Scripting Vulnerabilities
Input Validation Error 96228
Yes No
2017-02-15 12:00:00 2017-02-22 11:03:00
Toshitsugu Yoneyama of Mitsui Bussan Secure Directions, Inc.

- 受影响的程序版本

Apache Brooklyn 0.9.0
,Apache Brooklyn 0.10.0

- 不受影响的程序版本

Apache Brooklyn 0.10.0

- 漏洞讨论

Apache Brooklyn is prone to a cross-site request-forgery vulnerability and multiple cross-site scripting vulnerabilities.

An attacker may exploit these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, steal cookie-based authentication credentials, or perform unauthorized actions. Other attacks may also be possible.

Apache Brooklyn 0.9.0 and prior versions are vulnerable.

- 漏洞利用

An attacker must trick an unsuspecting victim into following a malicious URI to exploit these issues.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考