CVE-2016-6522
CVSS4.9
发布时间 :2017-03-07 11:59:00
修订时间 :2017-03-08 21:59:00
NMS    

[原文]Integer overflow in the uvm_map_isavail function in uvm/uvm_map.c in OpenBSD 5.9 allows local users to cause a denial of service (kernel panic) via a crafted mmap call, which triggers the new mapping to overlap with an existing mapping.


[CNNVD]CNNVD数据暂缺。


[机译]译文暂缺.

- CVSS (基础分值)

CVSS分值: 4.9 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-190 [整数溢出或超界折返]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-6522
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-6522
(官方数据源) NVD

- 其它链接及资源

http://ftp.openbsd.org/pub/OpenBSD/patches/5.9/common/023_uvmisavail.patch.sig
(PATCH)  CONFIRM  http://ftp.openbsd.org/pub/OpenBSD/patches/5.9/common/023_uvmisavail.patch.sig
http://www.openwall.com/lists/oss-security/2016/08/02/12
(VENDOR_ADVISORY)  MLIST  [oss-security] 20160802 Re: CVE Request: Denial-of-Service / Unexploitable Memory Corruption in mmap() on OpenBSD
http://www.openwall.com/lists/oss-security/2016/08/02/8
(VENDOR_ADVISORY)  MLIST  [oss-security] 20160802 CVE Request: Denial-of-Service / Unexploitable Memory Corruption in mmap() on OpenBSD
http://www.securityfocus.com/bid/92264
(UNKNOWN)  BID  92264

- 漏洞信息

OpenBSD CVE-2016-6522 Integer Overflow Vulnerability
Boundary Condition Error 92264
Yes No
2016-08-02 12:00:00 2016-08-02 12:00:00
Jesse Hertz and Tim Newsham

- 受影响的程序版本

OpenBSD OpenBSD 2.9
OpenBSD OpenBSD 2.8
OpenBSD OpenBSD 2.7
OpenBSD OpenBSD 2.6
OpenBSD OpenBSD 2.5
OpenBSD OpenBSD 2.4
OpenBSD OpenBSD 2.3
OpenBSD OpenBSD 2.2
OpenBSD OpenBSD 2.1
OpenBSD OpenBSD 2.0
OpenBSD OpenBSD 5.8
OpenBSD OpenBSD 5.5
OpenBSD OpenBSD 5.3
OpenBSD OpenBSD 5.2
OpenBSD OpenBSD 5.1
OpenBSD OpenBSD 5.0
OpenBSD OpenBSD 4.9
OpenBSD OpenBSD 4.8
OpenBSD OpenBSD 4.7
OpenBSD OpenBSD 4.6
OpenBSD OpenBSD 4.5
OpenBSD OpenBSD 4.5
OpenBSD OpenBSD 4.4
OpenBSD OpenBSD 4.3
OpenBSD OpenBSD 4.2
OpenBSD OpenBSD 4.1
OpenBSD OpenBSD 4.0
OpenBSD OpenBSD 3.9
OpenBSD OpenBSD 3.8
OpenBSD OpenBSD 3.7
OpenBSD OpenBSD 3.6
OpenBSD OpenBSD 3.5
OpenBSD OpenBSD 3.4
OpenBSD OpenBSD 3.3
OpenBSD OpenBSD 3.2
OpenBSD OpenBSD 3.1
OpenBSD OpenBSD 3.0
,OpenBSD Openbsd 5.9

- 不受影响的程序版本

OpenBSD Openbsd 5.9

- 漏洞讨论

OpenBSD is prone to an integer-overflow vulnerability.

An attacker can exploit this issue to cause a kernel panic, resulting in denial-of-service conditions; Due to the nature of this issue, arbitrary code execution may be possible but this has not been confirmed.

- 漏洞利用

The researcher has created a proof-of-concept to demonstrate the issue. Please see the references for more information.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站