CVE-2016-3734
CVSS6.8
发布时间 :2017-04-20 17:59:00
修订时间 :2017-04-27 13:05:50
NMS    

[原文]Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.


[CNNVD]CNNVD数据暂缺。


[机译]Google 翻译(企业版):

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-352 [跨站请求伪造(CSRF)]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:2.7.0:beta
cpe:/a:moodle:moodle:3.0.1
cpe:/a:moodle:moodle:3.0.2
cpe:/a:moodle:moodle:3.0.0:beta
cpe:/a:moodle:moodle:2.7.0:rc1
cpe:/a:moodle:moodle:2.7.0:rc2
cpe:/a:moodle:moodle:3.0.3
cpe:/a:moodle:moodle:2.7.12
cpe:/a:moodle:moodle:2.7.13
cpe:/a:moodle:moodle:2.7.10
cpe:/a:moodle:moodle:2.7.11
cpe:/a:moodle:moodle:2.7.7
cpe:/a:moodle:moodle:2.8.6
cpe:/a:moodle:moodle:2.9.5
cpe:/a:moodle:moodle:2.7.8
cpe:/a:moodle:moodle:2.8.7
cpe:/a:moodle:moodle:2.7.3
cpe:/a:moodle:moodle:2.8.2
cpe:/a:moodle:moodle:2.9.1
cpe:/a:moodle:moodle:2.7.4
cpe:/a:moodle:moodle:2.8.3
cpe:/a:moodle:moodle:2.9.2
cpe:/a:moodle:moodle:2.7.9
cpe:/a:moodle:moodle:2.8.8
cpe:/a:moodle:moodle:2.8.9
cpe:/a:moodle:moodle:2.7
cpe:/a:moodle:moodle:2.7.5
cpe:/a:moodle:moodle:2.8.4
cpe:/a:moodle:moodle:2.9.3
cpe:/a:moodle:moodle:2.7.6
cpe:/a:moodle:moodle:2.8.5
cpe:/a:moodle:moodle:2.9.4
cpe:/a:moodle:moodle:2.8
cpe:/a:moodle:moodle:2.8.10
cpe:/a:moodle:moodle:2.9
cpe:/a:moodle:moodle:3.0.0:rc3
cpe:/a:moodle:moodle:3.0.0:rc4
cpe:/a:moodle:moodle:3.0
cpe:/a:moodle:moodle:2.8.11
cpe:/a:moodle:moodle:2.7.1
cpe:/a:moodle:moodle:2.7.2
cpe:/a:moodle:moodle:2.8.1
cpe:/a:moodle:moodle:3.0.0:rc1
cpe:/a:moodle:moodle:3.0.0:rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3734
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-3734
(官方数据源) NVD

- 其它链接及资源

http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-53755
(PATCH)  CONFIRM  http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-53755
http://www.openwall.com/lists/oss-security/2016/05/17/4
(VENDOR_ADVISORY)  MLIST  [oss-security] 20160517 Moodle security release 3.0.4, 2.9.6, 2.8.12, 2.7.14
http://www.securityfocus.com/bid/91281
(VENDOR_ADVISORY)  BID  91281
http://www.securitytracker.com/id/1035902
(VENDOR_ADVISORY)  SECTRACK  1035902
https://bugzilla.redhat.com/show_bug.cgi?id=1335933
(VENDOR_ADVISORY)  CONFIRM  https://bugzilla.redhat.com/show_bug.cgi?id=1335933

- 漏洞信息

Apache Struts CVE-2016-4430 Cross-Site Request Forgery Vulnerability
Input Validation Error 91281
Yes No
2016-06-17 12:00:00 2016-07-06 03:03:00
Takeshi Terada.

- 受影响的程序版本

- 漏洞讨论

Apache Struts is prone to a cross-site request-forgery vulnerability because it fails to properly validate HTTP requests.

Exploiting this issue may allow a remote attacker to perform certain unauthorized actions and gain access to the affected application. Other attacks are also possible.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站