CVE-2015-6817
CVSS6.8
发布时间 :2017-05-23 00:29:01
修订时间 :2017-06-06 12:32:09
NMP    

[原文]PgBouncer 1.6.x before 1.6.1, when configured with auth_user, allows remote attackers to gain login access as auth_user via an unknown username.


[CNNVD]CNNVD数据暂缺。


[机译]帮助我们改进 Google 翻译

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-287 [认证机制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6817
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-6817
(官方数据源) NVD

- 其它链接及资源

http://comments.gmane.org/gmane.comp.db.postgresql.pgbouncer.general/1251
(UNKNOWN)  MISC  http://comments.gmane.org/gmane.comp.db.postgresql.pgbouncer.general/1251
http://www.openwall.com/lists/oss-security/2015/09/05/7
(PATCH)  MLIST  [oss-security] 20150905 Re: CVE Request: PgBouncer: failed auth_query lookup leads to connection as auth_user
https://github.com/pgbouncer/pgbouncer/commit/7ca3e5279d05fceb1e8a043c6f5b6f58dea3ed38
(PATCH)  CONFIRM  https://github.com/pgbouncer/pgbouncer/commit/7ca3e5279d05fceb1e8a043c6f5b6f58dea3ed38
https://github.com/pgbouncer/pgbouncer/issues/69
(PATCH)  CONFIRM  https://github.com/pgbouncer/pgbouncer/issues/69
https://pgbouncer.github.io/2015/09/pgbouncer-1-6-1
(VENDOR_ADVISORY)  CONFIRM  https://pgbouncer.github.io/2015/09/pgbouncer-1-6-1
https://security.gentoo.org/glsa/201701-24
(VENDOR_ADVISORY)  GENTOO  GLSA-201701-24

- 漏洞信息 (F140434)

Gentoo Linux Security Advisory 201701-24 (PacketStormID:F140434)
2017-01-11 00:00:00
Gentoo  security.gentoo.org
advisory,vulnerability
linux,gentoo
CVE-2015-4054,CVE-2015-6817
[点击下载]

Gentoo Linux Security Advisory 201701-24 - Multiple vulnerabilities have been found in PgBouncer, the worst of which may allow an attacker to bypass authentication. Versions less than 1.7.2 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201701-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PgBouncer: Multiple vulnerabilities
     Date: January 11, 2017
     Bugs: #550124, #600184
       ID: 201701-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PgBouncer, the worst of
which may allow an attacker to bypass authentication.

Background
==========

PgBouncer is a lightweight connection pooler for PostgreSQL.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/pgbouncer             < 1.7.2                    >= 1.7.2

Description
===========

Multiple vulnerabilities have been discovered in PgBouncer. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker might send a specially crafted package possibly
resulting in a Denial of Service condition. Furthermore, a remote
attacker might bypass authentication in configurations using the
"auth_user" feature.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PgBouncer users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/pgbouncer-1.7.2"

References
==========

[ 1 ] CVE-2015-4054
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4054
[ 2 ] CVE-2015-6817
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-6817

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201701-24

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


    
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站