CVE-2015-5675
CVSS7.2
发布时间 :2017-10-10 12:29:00
修订时间 :2017-11-05 16:24:20
NMPS    

[原文]The sys_amd64 IRET Handler in the kernel in FreeBSD 9.3 and 10.1 allows local users to gain privileges or cause a denial of service (kernel panic).


[CNNVD]CNNVD数据暂缺。


[机译]帮助我们改进 Google 翻译

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/o:freebsd:freebsd:9.3
cpe:/o:freebsd:freebsd:10.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5675
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-5675
(官方数据源) NVD

- 其它链接及资源

http://packetstormsecurity.com/files/133335/FreeBSD-Security-Advisory-IRET-Handler-Privilege-Escalation.html
(VENDOR_ADVISORY)  MISC  http://packetstormsecurity.com/files/133335/FreeBSD-Security-Advisory-IRET-Handler-Privilege-Escalation.html
http://www.securityfocus.com/archive/1/archive/1/536321/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20150825 FreeBSD Security Advisory FreeBSD-SA-15:21.amd64
http://www.securityfocus.com/bid/76485
(VENDOR_ADVISORY)  BID  76485
http://www.securitytracker.com/id/1033376
(VENDOR_ADVISORY)  SECTRACK  1033376
https://www.freebsd.org/security/advisories/FreeBSD-SA-15:21.amd64.asc
(VENDOR_ADVISORY)  FREEBSD  FreeBSD-SA-15:21

- 漏洞信息 (F133335)

FreeBSD Security Advisory - IRET Handler Privilege Escalation (PacketStormID:F133335)
2015-08-26 00:00:00
 
advisory,arbitrary,kernel,local
freebsd
CVE-2015-5675
[点击下载]

FreeBSD Security Advisory - If the kernel-mode IRET instruction generates an #SS or #NP exception, but the exception handler does not properly ensure that the right GS register base for kernel is reloaded, the userland GS segment may be used in the context of the kernel exception handler. By causing an IRET with #SS or #NP exceptions, a local attacker can cause the kernel to use an arbitrary GS base, which may allow escalated privileges or panic the system.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

=============================================================================
FreeBSD-SA-15:21.amd64                                      Security Advisory
                                                          The FreeBSD Project

Topic:          Local privilege escalation in IRET handler

Category:       core
Module:         sys_amd64
Announced:      2015-08-25
Credits:        Konstantin Belousov, Andrew Lutomirski
Affects:        FreeBSD 9.3 and FreeBSD 10.1
Corrected:      2015-03-31 00:59:30 UTC (stable/10, 10.1-STABLE)
                2015-08-25 20:48:58 UTC (releng/10.1, 10.1-RELEASE-p19)
                2015-03-31 01:08:51 UTC (stable/9, 9.3-STABLE)
                2015-08-25 20:49:05 UTC (releng/9.3, 9.3-RELEASE-p24)
CVE Name:       CVE-2015-5675

For general information regarding FreeBSD Security Advisories,
including descriptions of the fields above, security branches, and the
following sections, please visit <URL:https://security.FreeBSD.org/>.

I.   Background

FreeBSD/amd64 is commonly used on 64bit systems with AMD and Intel
CPU's.

The GS segment CPU register is used by both user processes and the
kernel to conveniently access state data: 32-bit user processes use the
register to manage per-thread data, while the kernel uses it to access
per-processor data.

The return from interrupt (IRET) instruction returns program control
from an interrupt handler to the interrupted context.

II.  Problem Description

If the kernel-mode IRET instruction generates an #SS or #NP exception,
but the exception handler does not properly ensure that the right GS
register base for kernel is reloaded, the userland GS segment may be
used in the context of the kernel exception handler.

III. Impact

By causing an IRET with #SS or #NP exceptions, a local attacker can
cause the kernel to use an arbitrary GS base, which may allow escalated
privileges or panic the system.

IV.  Workaround

No workaround is available.

V.   Solution

Perform one of the following:

1) Upgrade your vulnerable system to a supported FreeBSD stable or
release / security branch (releng) dated after the correction date,
and reboot the system.

2) To update your vulnerable system via a binary patch:

Systems running a RELEASE version of FreeBSD on the i386 or amd64
platforms can be updated via the freebsd-update(8) utility:

# freebsd-update fetch
# freebsd-update install

And reboot the system.

3) To update your vulnerable system via a source code patch:

The following patches have been verified to apply to the applicable
FreeBSD release branches.

a) Download the relevant patch from the location below, and verify the
detached PGP signature using your PGP utility.

# fetch https://security.FreeBSD.org/patches/SA-15:21/amd64.patch
# fetch https://security.FreeBSD.org/patches/SA-15:21/amd64.patch.asc
# gpg --verify amd64.patch.asc

b) Apply the patch.  Execute the following commands as root:

# cd /usr/src
# patch < /path/to/patch

c) Recompile your kernel as described in
<URL:https://www.FreeBSD.org/handbook/kernelconfig.html> and reboot the
system.

VI.  Correction details

The following list contains the correction revision numbers for each
affected branch.

Branch/path                                                      Revision
- -------------------------------------------------------------------------
stable/9/                                                         r280877
releng/9.3/                                                       r287147
stable/10/                                                        r280875
releng/10.1/                                                      r287146
- -------------------------------------------------------------------------

To see which files were modified by a particular revision, run the
following command, replacing NNNNNN with the revision number, on a
machine with Subversion installed:

# svn diff -cNNNNNN --summarize svn://svn.freebsd.org/base

Or visit the following URL, replacing NNNNNN with the revision number:

<URL:https://svnweb.freebsd.org/base?view=revision&revision=NNNNNN>

VII. References

<URL:https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5675>

The latest revision of this advisory is available at
<URL:https://security.FreeBSD.org/advisories/FreeBSD-SA-15:21.amd64.asc>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.1.7 (FreeBSD)

iQIcBAEBCgAGBQJV3Ne8AAoJEO1n7NZdz2rn5ncQANs2pS8xCowX+BM9LmKTUb2Y
eqGCvDetXV51/ljAOS10ubc4U0Zn2D5ACyz/DfiLIXVK8vkvlnJXFh3jSK6KIqPH
ionXa8zMedBoytZL8xIEFSpk9+cYGkGupIYEGu6CCHVZGJ5fVgTlnnazuXd4evbt
U1/7KNWt2H1R1j0YiYZ0MvhrIF35KqFmLOGf2JmZulqruwq91tYeMlv+7IY6vtPD
L8n5kTM7pudB3qznXd1PBMj1Y6YVG1O3WL4Stfyj93qDuMbJ+wfnao1ZKMBG0az8
IJITHrnTI+Xd4i/bbEoSmSN9V80S8uo/6J6JaXjtbrJfEqAMKhLrrcoMA7MHpKJQ
L4dv2HGL1n7xfOIfj5Qo2io/LUSye5lO54LtEKZfjhzqsTtNQl57BDAYZgbQp2/A
RsngIq3VrNcIJQK8F1Ba7SNL2+NVd091Wb+Z52837R5/D47jD2BhDia5eH6R5Opv
6kfzTJujbLi6b9RSn0OT+wAQbQ80qSmD+IwMXwAAg0mukthjTiJpqabpMWvMmfGO
mhfZBGqmf1Hx4lTczSRMLlRCmjOBc+BKioHT2ciE8QMX0WrHhkRuSBqY3euVTCMB
9+iU7eJ23tARTbG5wMmBNRsWJzhOKieM0UEsXxso+z8tMMX1Vh/e9ls2qm+ks876
WYT9/yPSsyU1z/AkHJU7
=nHGY
-----END PGP SIGNATURE-----
    

- 漏洞信息

FreeBSD CVE-2015-5675 Local Privilege Escalation Vulnerability
Design Error 76485
No Yes
2015-08-25 12:00:00 2015-08-25 12:00:00
Konstantin Belousov and Andrew Lutomirski

- 受影响的程序版本

- 漏洞讨论

FreeBSD is prone to a local privilege-escalation vulnerability.

Attackers can exploit this issue to gain elevated privileges. This may aid in further attacks.

- 漏洞利用

Currently, we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at: http://.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站