CVE-2014-9310
CVSS4.3
发布时间 :2017-06-07 17:29:00
修订时间 :2017-06-12 17:48:14
NMCS    

[原文]Cross-site scripting (XSS) vulnerability in the WordPress Backup to Dropbox plugin before 4.1 for WordPress.


[CNNVD]WordPress WordPress Backup to Dropbox插件跨站脚本漏洞(CNNVD-201506-205)

        

WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台,该平台支持在PHP和MySQL的服务器上架设个人博客网站。WordPress Backup to Dropbox是其中的一个用于将数据备份至Dropbox(在线存储服务)中的插件。

WordPress WordPress Backup to Dropbox插件中存在跨站脚本漏洞,该漏洞源于程序没有充分过滤用户提交的输入。当用户浏览受影响的网站时,其浏览器将执行攻击者提供的任意脚本代码。这可能导致攻击者窃取基于cookie的身份验证并发起其它攻击。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9310
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9310
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201506-205
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/75082
(VENDOR_ADVISORY)  BID  75082
https://security.szurek.pl/wordpress-backup-to-dropbox-40-reflected-xss.html
(VENDOR_ADVISORY)  MISC  https://security.szurek.pl/wordpress-backup-to-dropbox-40-reflected-xss.html
https://wordpress.org/plugins/wordpress-backup-to-dropbox/
(VENDOR_ADVISORY)  CONFIRM  https://wordpress.org/plugins/wordpress-backup-to-dropbox/

- 漏洞信息

WordPress WordPress Backup to Dropbox插件跨站脚本漏洞
跨站脚本
2015-06-11 00:00:00 2015-06-11 00:00:00
远程  
        

WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台,该平台支持在PHP和MySQL的服务器上架设个人博客网站。WordPress Backup to Dropbox是其中的一个用于将数据备份至Dropbox(在线存储服务)中的插件。

WordPress WordPress Backup to Dropbox插件中存在跨站脚本漏洞,该漏洞源于程序没有充分过滤用户提交的输入。当用户浏览受影响的网站时,其浏览器将执行攻击者提供的任意脚本代码。这可能导致攻击者窃取基于cookie的身份验证并发起其它攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        https://wordpress.org/plugins/wordpress-backup-to-dropbox/changelog/

- 漏洞信息

WordPress Backup to Dropbox Plugin 'wp-admin/admin.php' Cross Site Scripting Vulnerability
Input Validation Error 75082
Yes No
2015-06-09 12:00:00 2015-06-09 12:00:00
Kacper Szurek

- 受影响的程序版本

- 漏洞讨论

The WordPress Backup to Dropbox plugin for WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

- 漏洞利用

Attackers can exploit this issue by enticing an unsuspecting victim to follow a malicious URI.

The following example URI is available:

http://example.com/wp-admin/admin.php?page=backup-to-dropbox-premium&title=<script>alert(String.fromCharCode(88,83,83));</script>

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站