CVE-2014-2385
CVSS4.3
发布时间 :2014-07-22 10:55:08
修订时间 :2016-03-31 21:04:02
NMCP    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in the web UI in Sophos Anti-Virus for Linux before 9.6.1 allow local users to inject arbitrary web script or HTML via the (1) newListList:ExcludeFileOnExpression, (2) newListList:ExcludeFilesystems, or (3) newListList:ExcludeMountPaths parameter to exclusion/configure or (4) text:EmailServer or (5) newListList:Email parameter to notification/configure.


[CNNVD]Sophos Anti-Virus for Linux Web UI 跨站脚本漏洞(CNNVD-201407-524)

        

Sophos Anti-Virus for Linux是英国Sophos公司的一套用于Linux操作系统的反病毒软件。该软件可实时侦测和清除病毒、间谍软件、木马和蠕虫,确保台式机和笔记本电脑的全面网络保护。

Sophos Anti-Virus for Linux 9.5.1及之前版本的Web UI中存在两个跨站脚本漏洞,这些漏洞源于exclusion/configure脚本没有充分过滤‘newListList:ExcludeFileOnExpression’、‘newListList:ExcludeFilesystems’、‘newListList:ExcludeMountPaths’参数,notification/configure脚本没有充分过滤‘text:EmailServer’和‘newListList:Email’参数。远程攻击者可利用这些漏洞执行任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2385
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2385
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201407-524
(官方数据源) CNNVD

- 其它链接及资源

https://www.portcullis-security.com/security-research-and-downloads/security-advisories/cve-2014-2385/
(UNKNOWN)  MISC  https://www.portcullis-security.com/security-research-and-downloads/security-advisories/cve-2014-2385/
http://www.sophos.com/en-us/support/knowledgebase/121135.aspx
(VENDOR_ADVISORY)  CONFIRM  http://www.sophos.com/en-us/support/knowledgebase/121135.aspx
http://www.securitytracker.com/id/1030467
(UNKNOWN)  SECTRACK  1030467
http://www.securityfocus.com/archive/1/archive/1/532558/100/0/threaded
(UNKNOWN)  BUGTRAQ  20140625 CVE-2014-2385 - Multiple Cross Site Scripting in Sophos Antivirus Configuration Console (Linux)
http://seclists.org/fulldisclosure/2014/Jun/126
(UNKNOWN)  FULLDISC  20140625 CVE-2014-2385 - Multiple Cross Site Scripting in Sophos Antivirus Configuration Console (Linux)
http://packetstormsecurity.com/files/127228/Sophos-Antivirus-9.5.1-Cross-Site-Scripting.html
(UNKNOWN)  MISC  http://packetstormsecurity.com/files/127228/Sophos-Antivirus-9.5.1-Cross-Site-Scripting.html

- 漏洞信息

Sophos Anti-Virus for Linux Web UI 跨站脚本漏洞
中危 跨站脚本
2014-07-23 00:00:00 2014-07-23 00:00:00
远程  
        

Sophos Anti-Virus for Linux是英国Sophos公司的一套用于Linux操作系统的反病毒软件。该软件可实时侦测和清除病毒、间谍软件、木马和蠕虫,确保台式机和笔记本电脑的全面网络保护。

Sophos Anti-Virus for Linux 9.5.1及之前版本的Web UI中存在两个跨站脚本漏洞,这些漏洞源于exclusion/configure脚本没有充分过滤‘newListList:ExcludeFileOnExpression’、‘newListList:ExcludeFilesystems’、‘newListList:ExcludeMountPaths’参数,notification/configure脚本没有充分过滤‘text:EmailServer’和‘newListList:Email’参数。远程攻击者可利用这些漏洞执行任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.sophos.com/en-us/support/knowledgebase/121135.aspx

- 漏洞信息 (F127228)

Sophos Antivirus 9.5.1 Cross Site Scripting (PacketStormID:F127228)
2014-06-26 00:00:00
Pablo Catalina  portcullis-security.com
advisory,javascript,xss
linux
CVE-2014-2385
[点击下载]

The Configuration Console of Sophos Antivirus version 9.5.1 (Linux) does not sanitize several input parameters before sending them back to the browser, so an attacker could inject code inside these parameters, including JavaScript code.

*ERROR*    
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站