CVE-2014-0097
CVSS7.5
发布时间 :2017-05-25 13:29:00
修订时间 :2017-06-07 10:23:01
NMCPS    

[原文]The ActiveDirectoryLdapAuthenticator in Spring Security 3.2.0 to 3.2.1 and 3.1.0 to 3.1.5 does not check the password length. If the directory allows anonymous binds then it may incorrectly authenticate a user who supplies an empty password.


[CNNVD]GoPivotalSpring Security ActiveDirectoryLdapAuthenticator 远程身份验证绕过漏洞(CNNVD-201406-520)

        

GoPivotal Spring Security是美国GoPivotal公司的一套为基于Spring的应用程序提供说明性安全保护的安全框架。

GoPivotal Spring Security中存在远程身份验证绕过漏洞。攻击者可利用该漏洞绕过身份验证机制,执行未授权操作。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-287 [认证机制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:pivotal_software:spring_security:3.1.1
cpe:/a:pivotal_software:spring_security:3.2.0
cpe:/a:pivotal_software:spring_security:3.1.2
cpe:/a:pivotal_software:spring_security:3.2.1
cpe:/a:pivotal_software:spring_security:3.1.0
cpe:/a:pivotal_software:spring_security:3.1.5
cpe:/a:pivotal_software:spring_security:3.1.3
cpe:/a:pivotal_software:spring_security:3.1.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0097
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-0097
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201406-520
(官方数据源) CNNVD

- 其它链接及资源

https://pivotal.io/security/cve-2014-0097
(VENDOR_ADVISORY)  CONFIRM  https://pivotal.io/security/cve-2014-0097

- 漏洞信息

GoPivotalSpring Security ActiveDirectoryLdapAuthenticator 远程身份验证绕过漏洞
2014-06-25 00:00:00 2014-06-25 00:00:00
远程  
        

GoPivotal Spring Security是美国GoPivotal公司的一套为基于Spring的应用程序提供说明性安全保护的安全框架。

GoPivotal Spring Security中存在远程身份验证绕过漏洞。攻击者可利用该漏洞绕过身份验证机制,执行未授权操作。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
        http://spring.io/

- 漏洞信息 (F125681)

Spring Security 3.2.1 / 3.1.5 Authentication Bypass (PacketStormID:F125681)
2014-03-12 00:00:00
Pivotal Security Team  
advisory
CVE-2014-0097
[点击下载]

The ActiveDirectoryLdapAuthenticator does not check the password length in Spring Security. If the directory allows anonymous binds then it may incorrectly authenticate a user who supplies an empty password. Spring Security versions 3.2.0 through 3.2.1 and 3.1.0 through 3.1.5 are affected.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

CVE-2014-0097 Blank password may bypass user authentication

Severity: Important

Vendor: Spring by Pivotal

Versions Affected:
- - Spring Security 3.2.0 to 3.2.1
- - Spring Security 3.1.0 to 3.1.5

Description:
The ActiveDirectoryLdapAuthenticator does not check the password length. If the
directory allows anonymous binds then it may incorrectly authenticate a user who
supplies an empty password.

Mitigation:
Users of affected versions should apply the following mitigation:
- - Users of 3.2.x should upgrade to 3.2.2

Credit:
This issue was identified by the Spring Development team.

References:
http://www.gopivotal.com/security/cve-2014-0097
https://jira.springsource.org/browse/SEC-2500
https://github.com/spring-projects/spring-security/commit/88559882e967085c47a7e1dcbc4dc32c2c796868
https://github.com/spring-projects/spring-security/commit/7dbb8e777ece8675f3333a1ef1cb4d6b9be80395
https://github.com/spring-projects/spring-security/commit/a7005bd74241ac8e2e7b38ae31bc4b0f641ef973

History:
2014-Mar-11: Initial vulnerability report published.
2014-Mar-11: Affected versions corrected to add 3.1.0 to 3.1.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32) - WinPT 1.2.0

iQIcBAEBAgAGBQJTH4PiAAoJEKSZXFdK82XakpEP/AofBt17ZjSs4MeFcgm/zt1e
tad8nNlYPRxjoUQYexNGLAu6JPIdaaZ1dZib+6vLwX3iKpMNq2dikkiVFk9qPSQY
It/o58+n3e+La5KiEKpUHUnFuUfaOrcI6iojDlb/tIRKZB3UR8c8X562rYNDsMAJ
QgAFaEvlxtNlB273Dq3AuIugpKB1E3Ivk2AFw9n7esutvKac42S8RaCw3FM+t8Hp
OsbkroB8OE9qfi/MSh4loLZDdHakYgRy/mdW/5FYzrnbiOUNIzeyph3KiWFb5col
ox2k9DEDsBbve/jATg/hsL0NvOIIqWA7mO+K/8XiGo4OnUkcDginCrEx01r36YLM
wHIfnjQp6tgngFMC1sJBqaYH5bQ4p6HSiYwWutUTRvRUoXDe3YvPra37lWtgVfAv
otYmZ8BZiQrzMiE5J1UIshekJV6dEhani3kyi3htCvOiBCS2+YMYzKgg16OgVcf5
JYmQKk/yE+ZEeWdTmM0gGK44axUQVNWZpG84JG/n7gDU+/yNO//93/vnID2JE5VK
CzAcP2fazzK4D2u5t1k7JNfArDJ82SrVjEzY0RuZiu+ui/32kidIJY757rMbPV1k
+wiE9429N4vsOisHavNladmUGl2vb5ImcVHiDy6ZyXyF8Xu4lE5YuhLzA5qZ4Ta/
n96+1qDQQZB4HhRKAnIZ
=XpO8
-----END PGP SIGNATURE-----
    

- 漏洞信息

Spring Security ActiveDirectoryLdapAuthenticator Authentication Bypass Vulnerability
Design Error 66135
Yes No
2014-03-12 12:00:00 2014-03-12 12:00:00
Spring Development team

- 受影响的程序版本

- 漏洞讨论

Spring Security is prone to a remote authentication-bypass vulnerability.

An attacker can exploit this issue to bypass the authentication mechanism and perform unauthorized actions. This may aid in further attacks.

- 漏洞利用

An attacker can exploit this issue using a web browser.

- 解决方案

Updates are available. Please see the references or vendor advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站