CVE-2012-3421
CVSS5.0
发布时间 :2012-08-27 19:55:02
修订时间 :2013-02-06 23:57:15
NMCOP    

[原文]The pduread function in pdu.c in libpcp in Performance Co-Pilot (PCP) before 3.6.5 does not properly time out connections, which allows remote attackers to cause a denial of service (pmcd hang) by sending individual bytes of a PDU separately, related to an "event-driven programming flaw."


[CNNVD]Performance Co-Pilot ‘pduread()’函数安全漏洞(CNNVD-201208-301)

        Performance Co-Pilot (PCP)是由SGI开发的一套支持系统级性能监视的服务,其中的 一个应用程序叫做"pmpost",默认安装时所有者为root,且设置了setuid位。
        Performance Co-Pilot 3.6.5之前版本中存在安全漏洞,恶意用户可利用导致DoS(拒绝服务),进而操控受影响系统。该漏洞源于处理某些事件时,‘pduread()’函数(libpcp/src/pdu.c)内存在错误。攻击者可利用该漏洞导致崩溃。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:sgi:performance_co-pilot:2.1.5SGI Performance Co-Pilot 2.1.5
cpe:/a:sgi:performance_co-pilot:2.1.11SGI Performance Co-Pilot 2.1.11
cpe:/a:sgi:performance_co-pilot:2.1.7SGI Performance Co-Pilot 2.1.7
cpe:/a:sgi:performance_co-pilot:2.1.6SGI Performance Co-Pilot 2.1.6
cpe:/a:sgi:performance_co-pilot:2.1.4SGI Performance Co-Pilot 2.1.4
cpe:/a:sgi:performance_co-pilot:2.1.3SGI Performance Co-Pilot 2.1.3
cpe:/a:sgi:performance_co-pilot:2.1.8SGI Performance Co-Pilot 2.1.8
cpe:/a:sgi:performance_co-pilot:2.1.10SGI Performance Co-Pilot 2.1.10
cpe:/a:sgi:performance_co-pilot:2.2SGI Performance Co-Pilot 2.2
cpe:/a:sgi:performance_co-pilot:2.1.1SGI Performance Co-Pilot 2.1.1
cpe:/a:sgi:performance_co-pilot:2.1.2SGI Performance Co-Pilot 2.1.2
cpe:/a:sgi:performance_co-pilot:2.1.9SGI Performance Co-Pilot 2.1.9
cpe:/a:sgi:performance_co-pilot:3.6.4SGI Performance Co-Pilot 3.6.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3421
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-3421
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201208-301
(官方数据源) CNNVD

- 其它链接及资源

https://hermes.opensuse.org/messages/15540172
(UNKNOWN)  SUSE  openSUSE-SU-2012:1081
https://hermes.opensuse.org/messages/15540133
(UNKNOWN)  SUSE  openSUSE-SU-2012:1079
https://hermes.opensuse.org/messages/15471040
(UNKNOWN)  SUSE  openSUSE-SU-2012:1036
https://bugzilla.redhat.com/show_bug.cgi?id=841706
(UNKNOWN)  MISC  https://bugzilla.redhat.com/show_bug.cgi?id=841706
http://www.openwall.com/lists/oss-security/2012/08/16/1
(UNKNOWN)  MLIST  [oss-security] 20120816 pcp: Multiple security flaws
http://www.debian.org/security/2012/dsa-2533
(UNKNOWN)  DEBIAN  DSA-2533
http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=9ba85dca940de976176ce196fd5e3c4170936354
(UNKNOWN)  CONFIRM  http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=9ba85dca940de976176ce196fd5e3c4170936354
http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=blob;f=CHANGELOG;h=16c9cbb2f61d909487ea1c3171f4ab33e5648ac5;hb=fe51067ae869a4d59f350ac319b09edcb77ac8e6
(UNKNOWN)  CONFIRM  http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=blob;f=CHANGELOG;h=16c9cbb2f61d909487ea1c3171f4ab33e5648ac5;hb=fe51067ae869a4d59f350ac319b09edcb77ac8e6
http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00024.html
(UNKNOWN)  SUSE  SUSE-SU-2013:0190
http://lists.fedoraproject.org/pipermail/package-announce/2012-August/085333.html
(UNKNOWN)  FEDORA  FEDORA-2012-12076
http://lists.fedoraproject.org/pipermail/package-announce/2012-August/085324.html
(UNKNOWN)  FEDORA  FEDORA-2012-12024

- 漏洞信息

Performance Co-Pilot ‘pduread()’函数安全漏洞
中危 设计错误
2012-08-20 00:00:00 2012-08-20 00:00:00
远程  
        Performance Co-Pilot (PCP)是由SGI开发的一套支持系统级性能监视的服务,其中的 一个应用程序叫做"pmpost",默认安装时所有者为root,且设置了setuid位。
        Performance Co-Pilot 3.6.5之前版本中存在安全漏洞,恶意用户可利用导致DoS(拒绝服务),进而操控受影响系统。该漏洞源于处理某些事件时,‘pduread()’函数(libpcp/src/pdu.c)内存在错误。攻击者可利用该漏洞导致崩溃。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://lists.fedoraproject.org/pipermail/package-announce/2012-August/085333.html

- 漏洞信息 (F115845)

Debian Security Advisory 2533-1 (PacketStormID:F115845)
2012-08-24 00:00:00
Debian  debian.org
advisory,vulnerability
linux,debian
CVE-2012-3418,CVE-2012-3419,CVE-2012-3420,CVE-2012-3421
[点击下载]

Debian Linux Security Advisory 2533-1 - It was discovered that Performance Co-Pilot (pcp), a framework for performance monitoring, contains several vulnerabilities.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2533-1                   security@debian.org
http://www.debian.org/security/                            Florian Weimer
August 23, 2012                        http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : pcp
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2012-3418 CVE-2012-3419 CVE-2012-3420 CVE-2012-3421

It was discovered that Performance Co-Pilot (pcp), a framework for
performance monitoring, contains several vulnerabilites.

CVE-2012-3418
	Multiple buffer overflows in the PCP protocol decoders can
	cause PCP clients and servers to crash or, potentially,
	execute arbitrary code while processing crafted PDUs.

CVE-2012-3419
	The "linux" PMDA used by the pmcd daemon discloses sensitive
	information from the /proc file system to unauthenticated
	clients.

CVE-2012-3420
	Multiple memory leaks processing crafted requests can cause
	pmcd to consume large amounts of memory and eventually crash.

CVE-2012-3421
	Incorrect event-driven programming allows malicious clients to
	prevent other clients from accessing the pmcd daemon.

To address the information disclosure vulnerability, CVE-2012-3419, a
new "proc" PMDA was introduced, which is disabled by default.  If you
need access to this information, you need to enable the "proc" PMDA.

For the stable distribution (squeeze), this problem has been fixed in
version 3.3.3-squeeze2.

For the unstable distribution (sid), this problem has been fixed in
version 3.6.5.

We recommend that you upgrade your pcp packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQEcBAEBAgAGBQJQNoiAAAoJEL97/wQC1SS+RZkH/jWSrAvDXic16J897CzMaNQf
EseDAqXTG9ew01Pw6PHgmNa+XWqHgS7e5dOS/cyJ/QCkNr5OzIcnw6HN4FDOSQQe
gW3n4cAxhcKIynhXPhBK7Ja/RyFG5Y4+8XEnM14wNXk+8cXd4y2x7DtJDUm3eFuw
pI2+vlP670N7yy0xKNSD/YxbHCYms2tcKlSX8E2XokXM3gYlg1dSg6xA3AIvLPPm
4vMvRZE9wWrdMAFh6HocNIE/BR70lhBzmd4pTMMVIULdPwRFk/jovBzM3YpwkYeF
zub0g+77hmp2lc+PhzauAL5sAJ2/Ms6AG37bIlSkiFy0yPb+9g3V0Zcn8h4uum4=
=4hVC
-----END PGP SIGNATURE-----


    

- 漏洞信息

84799
Performance Co-Pilot libpcp/src/pdu.c pduread() Function Event Handling Remote DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Availability Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

Performance Co-Pilot contains a flaw that may allow a remote denial of service. The issue is triggered when an error occurs in the pduread() function of libpcp/src/pdu.c during the handling of events. This may allow a remote attacker to supply bytes one by one, blocking the daemon from performing others functions and resulting in a loss of availability.

- 时间线

2012-08-16 Unknow
Unknow 2012-08-16

- 解决方案

Upgrade to version 3.6.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站