发布时间 :2006-07-27 07:04:00
修订时间 :2016-10-17 23:40:28

[原文]Cross-site scripting (XSS) vulnerability in guestbook.php in TP-Book 1.00 and earlier allows remote attackers to inject arbitrary web script or HTML via the name parameter.

[CNNVD]TP Book Guestbook.PHP HTML注入漏洞(CNNVD-200607-473)

        TP-Book 1.00 及更早版本中的 guestbook.php 存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过 name 参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  FULLDISC  20060725 TP-Book <= 1.00 Cross Site Scripting
(UNKNOWN)  BUGTRAQ  20060725 TP-Book <= 1.00 Cross Site Scripting Vulnerabilities
(UNKNOWN)  BID  19159
(UNKNOWN)  VUPEN  ADV-2006-2980
(UNKNOWN)  XF  tpbook-guestbook-xss(27964)

- 漏洞信息

TP Book Guestbook.PHP HTML注入漏洞
中危 跨站脚本
2006-07-27 00:00:00 2006-08-27 00:00:00
        TP-Book 1.00 及更早版本中的 guestbook.php 存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过 name 参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

TP-Book guestbook.php name Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-07-25 Unknow
2006-07-25 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

TP Book Guestbook.PHP HTML Injection Vulnerability
Input Validation Error 19159
Yes No
2006-07-25 12:00:00 2007-08-07 09:24:00
Tamriel is credited with the discovery of this vulnerability.

- 受影响的程序版本

Tobias Kloy TP-Book 1.0
Tobias Kloy TP-Book 1.0.1

- 不受影响的程序版本

Tobias Kloy TP-Book 1.0.1

- 漏洞讨论

TP-Book is prone to an HTML-injection vulnerability because it fails to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would execute in the context of the affected website, potentially allowing an attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user; other attacks are also possible.

TP-Book 1.0 and prior versions are vulnerable to this issue.

- 漏洞利用

Attackers can exploit this issue via a web client.

- 解决方案

The vendor released an update to address this issue. Please see the references for more information.

- 相关参考