发布时间 :2006-07-26 21:04:00
修订时间 :2011-03-07 21:39:38

[原文]Multiple SQL injection vulnerabilities in links.php in Gonafish LinksCaffe 3.0 allow remote attackers to execute arbitrary SQL commands via the (1) offset and (2) limit parameters, (3) newdays parameter in a new action, and the (4) link_id parameter in a deadlink action. NOTE: this issue can also be used for path disclosure by a forced SQL error, or to modify PHP files using OUTFILE.

[CNNVD]Gonafish LinksCaffe 'links.php' 多个SQL注入漏洞(CNNVD-200607-446)

        Gonafish LinksCaffe 3.0中的links.php存在多个SQL注入漏洞。远程攻击者可以借助(1)offset和(2)limit参数,(3)new操作中的newdays参数,以及(4)deadlink操作中的link_id参数,执行任意SQL命令。注意: 此问题也可用于通过强制SQL错误实现路径泄露,或利用OUTFILE修改PHP文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-2983
(UNKNOWN)  BID  19149
(UNKNOWN)  BUGTRAQ  20060725 LinksCaffe 3.0 SQL injection/Command Execution Vulnerabilties
(UNKNOWN)  XF  linkscaffe-links-path-disclosure(27962)
(UNKNOWN)  XF  linkscaffe-links-sql-injection(27961)

- 漏洞信息

Gonafish LinksCaffe 'links.php' 多个SQL注入漏洞
高危 SQL注入
2006-07-26 00:00:00 2006-07-27 00:00:00
        Gonafish LinksCaffe 3.0中的links.php存在多个SQL注入漏洞。远程攻击者可以借助(1)offset和(2)limit参数,(3)new操作中的newdays参数,以及(4)deadlink操作中的link_id参数,执行任意SQL命令。注意: 此问题也可用于通过强制SQL错误实现路径泄露,或利用OUTFILE修改PHP文件。

- 公告与补丁


- 漏洞信息

LinksCaffe links.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

LinksCaffe contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the links.php script not properly sanitizing user-supplied input to the 'cat', 'link_id', 'newdays', and 'offset' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database. When the magic_quote_gpc PHP option is disabled an attacker may use this flaw to create a shell in a writable folder that can be used to run arbitrary commands. Additionally, if a failed query is performed, the program will disclose the softwares installation path. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks.

- 时间线

2006-07-25 Unknow
2006-07-25 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者