发布时间 :2006-07-25 19:04:00
修订时间 :2008-09-05 17:08:13

[原文]** DISPUTED ** PHP remote file inclusion vulnerability in upgrader.php in Vanilla CMS 1.0.1 and earlier, when /conf/old_settings.php exists, allows remote attackers to execute arbitrary PHP code via a URL in the RootDirectory parameter. NOTE: this issue has been disputed by a third party who states that the RootDirectory parameter is initialized before being used, for version 1.0. CVE analysis concurs with the dispute, but it is unclear whether older versions are affected.

[CNNVD]Lussumo Vanilla 'upgrader.php' RootDirectory远程文件包含漏洞(CNNVD-200607-424)


- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  19127
(UNKNOWN)  BUGTRAQ  20060805 Re: Vanilla CMS <= 1.0.1 (RootDirectory) Remote file inclusion Vuln.
(UNKNOWN)  BUGTRAQ  20060723 Vanilla CMS <= 1.0.1 (RootDirectory) Remote file inclusion Vuln.
(UNKNOWN)  VIM  20060725 Vanilla CMS
(UNKNOWN)  VIM  20060724 Vanilla CMS

- 漏洞信息

Lussumo Vanilla 'upgrader.php' RootDirectory远程文件包含漏洞
中危 输入验证
2006-07-25 00:00:00 2013-01-08 00:00:00

- 公告与补丁


- 漏洞信息

Vanilla CMS upgrader.php RootDirectory Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Vanilla CMS has been reported to contain a flaw that may allow a remote attacker to execute arbitrary commands. The issue is supposedly due to the upgrader.php script not properly sanitizing user input supplied to the 'RootDirectory' variable. However, subsequent evaluation indicates that an attacker can not manipulate the variable as reported.

- 时间线

2006-07-23 Unknow
Unknow Unknow

- 解决方案

The vulnerability reported is incorrect. No solution required.

- 相关参考

- 漏洞作者