发布时间 :2006-07-25 19:04:00
修订时间 :2011-03-07 21:39:35

[原文]Buffer overflow in Quick 'n Easy FTP Server 3.0 allows remote authenticated users to execute arbitrary commands via a long argument to the LIST command, a different issue than CVE-2006-2027.

[CNNVD]Pablo Software Solutions Quick 'n Easy FTP Server LIST 命令缓冲区溢出漏洞(CNNVD-200607-413)

        Quick 'n Easy FTP Server 3.0存在缓冲区溢出。远程认证用户可以借助一个对LIST命令的长自变量,执行任意命令。

- CVSS (基础分值)

CVSS分值: 6.5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-2875
(UNKNOWN)  BID  19067
(UNKNOWN)  XF  quickneasy-list-command-bo(27839)

- 漏洞信息

Pablo Software Solutions Quick 'n Easy FTP Server LIST 命令缓冲区溢出漏洞
中危 缓冲区溢出
2006-07-25 00:00:00 2006-07-27 00:00:00
        Quick 'n Easy FTP Server 3.0存在缓冲区溢出。远程认证用户可以借助一个对LIST命令的长自变量,执行任意命令。

- 公告与补丁


- 漏洞信息

Quick 'n Easy FTP Server LIST Command Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in Quick n Easy FTP Server. The product fails to perform correct boundary checks on LIST commands resulting in a buffer overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2006-07-18 Unknow
2006-07-18 Unknow

- 解决方案

Upgrade to version 3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Pablo Software Solutions Quick 'n Easy FTP Server LIST Command Buffer Overflow Vulnerability
Boundary Condition Error 19067
Yes No
2006-07-19 12:00:00 2010-06-03 04:50:00
h07 is credited with the discovery of this vulnerability.

- 受影响的程序版本

Pablo Software Solutions Quick And Easy FTP Server 3.0.2
Pablo Software Solutions Quick And Easy FTP Server 3.3

- 漏洞讨论

Quick 'n Easy FTP Server is prone to a buffer-overflow vulnerability because it fails to do proper bounds checking on user-supplied data before storing it in a finite-sized buffer.

An attacker can exploit this issue to execute arbitrary machine code in the context of the affected server application, likely with SYSTEM-level privileges.

- 漏洞利用

Exploit code has been provided:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考