CVE-2006-3761
CVSS4.3
发布时间 :2006-07-21 10:03:00
修订时间 :2008-09-10 16:24:43
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in inc/functions_post.php in MyBB (aka MyBulletinBoard) 1.0 RC2 through 1.1.4 allows remote attackers to inject arbitrary web script or HTML via a javascript URI with an SGML numeric character reference in the url BBCode tag, as demonstrated using "javascript".


[CNNVD]MyBB 'functions_post.php'跨站脚本攻击(XSS) 漏洞(CNNVD-200607-348)

        MyBB (又称 MyBulletinBoard) 1.0 RC2 到1.1.4中的inc/functions_post.php 存在跨站脚本攻击(XSS) 漏洞。远程攻击者可以借助在 url BBCode标签中有SGML数字字符引用的javascript URI ,注入任意Web脚本或HTML,比如使用 "javascript"。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:mybulletinboard:mybulletinboard:1.00_rc4
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc1
cpe:/a:mybulletinboard:mybulletinboard:1.04
cpe:/a:mybulletinboard:mybulletinboard:1.0_rc2
cpe:/a:mybulletinboard:mybulletinboard:1.0.2
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc2
cpe:/a:mybulletinboard:mybulletinboard:1.1
cpe:/a:mybulletinboard:mybulletinboard:1.0_rc4
cpe:/a:mybulletinboard:mybulletinboard:1.1.4
cpe:/a:mybulletinboard:mybulletinboard:1.0.4
cpe:/a:mybulletinboard:mybulletinboard:1.1.3
cpe:/a:mybulletinboard:mybulletinboard:1.0_pr2
cpe:/a:mybulletinboard:mybulletinboard:1.1.1
cpe:/a:mybulletinboard:mybulletinboard:1.0_final
cpe:/a:mybulletinboard:mybulletinboard:1.01
cpe:/a:mybulletinboard:mybulletinboard:1.0.3
cpe:/a:mybulletinboard:mybulletinboard:1.1.2
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc4_security_patch
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc3
cpe:/a:mybulletinboard:mybulletinboard:1.0_preview_release_2
cpe:/a:mybulletinboard:mybulletinboard:1.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3761
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3761
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-348
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/27444
(PATCH)  XF  mybb-url-tag-xss(27444)
http://www.securityfocus.com/bid/18702
(PATCH)  BID  18702
http://www.osvdb.org/26808
(PATCH)  OSVDB  26808
http://www.mybboard.com/archive.php?nid=15
(PATCH)  CONFIRM  http://www.mybboard.com/archive.php?nid=15
http://secunia.com/advisories/20873
(VENDOR_ADVISORY)  SECUNIA  20873
http://community.mybboard.net/showthread.php?tid=10115
(PATCH)  CONFIRM  http://community.mybboard.net/showthread.php?tid=10115
http://www.securityfocus.com/archive/1/archive/1/438588/100/200/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060628 [KAPDA]MyBB 1.1.4~function_post.php~XSS Attack In URL tag
http://securityreason.com/securityalert/1257
(UNKNOWN)  SREASON  1257
http://myimei.com/security/2006-06-22/mybb-114-function_postphpxss-attack-in-url-tag.html
(UNKNOWN)  MISC  http://myimei.com/security/2006-06-22/mybb-114-function_postphpxss-attack-in-url-tag.html

- 漏洞信息

MyBB 'functions_post.php'跨站脚本攻击(XSS) 漏洞
中危 跨站脚本
2006-07-21 00:00:00 2007-08-13 00:00:00
远程  
        MyBB (又称 MyBulletinBoard) 1.0 RC2 到1.1.4中的inc/functions_post.php 存在跨站脚本攻击(XSS) 漏洞。远程攻击者可以借助在 url BBCode标签中有SGML数字字符引用的javascript URI ,注入任意Web脚本或HTML,比如使用 "javascript"。

- 公告与补丁

        

- 漏洞信息

26808
MyBulletinBoard (MyBB) url BBCode Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-06-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站