CVE-2006-3684
CVSS7.5
发布时间 :2006-07-21 10:03:00
修订时间 :2017-07-19 21:32:29
NMCO    

[原文]PHP remote file inclusion vulnerability in calendar.php in SoftComplex PHP Event Calendar 1.4 allows remote attackers to execute arbitrary PHP code via a URL in the path_to_calendar parameter, which overwrites the $path_to_calendar variable from an extract function call.


[CNNVD]PHP Event Calendar 'Calendar.PHP'远程文件包含漏洞(CNNVD-200607-341)

        SoftComplex PHP Event Calendar 1.4中的calendar.php 存在PHP远程文件包含漏洞。 远程攻击者可以借助path_to_calendar参数中的URL,从extract函数调用中重写$path_to_calendar变量,从而执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3684
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3684
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-341
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/440265/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060716 PHP Event Calendar versi 1.4 (path_to_calendar) Remote File Inclusion
http://www.securityfocus.com/bid/18965
(UNKNOWN)  BID  18965
http://www.solpotcrew.org/adv/solpot-adv-01.txt
(UNKNOWN)  MISC  http://www.solpotcrew.org/adv/solpot-adv-01.txt
http://www.vupen.com/english/advisories/2006/2848
(UNKNOWN)  VUPEN  ADV-2006-2848
https://exchange.xforce.ibmcloud.com/vulnerabilities/27766
(UNKNOWN)  XF  phpeventcalendar-calendar-file-include(27766)

- 漏洞信息

PHP Event Calendar 'Calendar.PHP'远程文件包含漏洞
高危 输入验证
2006-07-21 00:00:00 2006-08-15 00:00:00
远程  
        SoftComplex PHP Event Calendar 1.4中的calendar.php 存在PHP远程文件包含漏洞。 远程攻击者可以借助path_to_calendar参数中的URL,从extract函数调用中重写$path_to_calendar变量,从而执行任意PHP代码。

- 公告与补丁

        

- 漏洞信息

27359
SoftComplex PHP Event Calendar calendar.php path_to_calendar Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-07-15 Unknow
2006-07-15 Unknow

- 解决方案

Upgrade to version 1.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站