发布时间 :2006-07-13 15:05:00
修订时间 :2011-09-06 00:00:00

[原文]Multiple stack-based buffer overflows in Audacious AdPlug 2.0 and earlier allow remote user-assisted attackers to execute arbitrary code via large (1) DTM and (2) S3M files.


        Audacious AdPlug 2.0及之前版本存在多个基于堆栈的缓冲区溢出。远程用户协助式攻击者可以借助(1) DTM和(2) S3M大文件,执行任意代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  adplug-s3m-file-bo(27674)
(UNKNOWN)  XF  adplug-dtm-file-bo(27673)
(UNKNOWN)  BID  18859
(UNKNOWN)  BUGTRAQ  20060706 Various heap and stack overflow bugs in AdPlug library 2.0 (CVS 04 Jul 2006)

- 漏洞信息

中危 缓冲区溢出
2006-07-13 00:00:00 2006-08-02 00:00:00
        Audacious AdPlug 2.0及之前版本存在多个基于堆栈的缓冲区溢出。远程用户协助式攻击者可以借助(1) DTM和(2) S3M大文件,执行任意代码。

- 公告与补丁


- 漏洞信息

AdPlug dtm.cpp DTM File Processing Overflow
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

A local overflow exists in AdPlug. The 'dtm.cpp' library fails to sanitize user controlled fields in a DTM file resulting in a buffer overflow. With a specially crafted DTM file, an attacker can compromise applications using the library resulting in a loss of integrity.

- 时间线

2006-07-06 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

AdPlug Multiple Remote File Buffer Overflow Vulnerabilities
Boundary Condition Error 18859
Yes No
2006-07-06 12:00:00 2006-09-12 11:12:00
Discovery is credited to Luigi Auriemma <>.

- 受影响的程序版本

Gentoo Linux
Audacious Audacious 1.0
AdPlug AdPlug 2.0
Audacious Audacious 1.1

- 不受影响的程序版本

Audacious Audacious 1.1

- 漏洞讨论

The AdPlug library is affected by multiple remote buffer-overflow vulnerabilities. These issues are due to the library's failure to properly bounds-check user-supplied input before copying it into insufficiently sized memory buffers.

These issues allow remote attackers to execute arbitrary machine code in the context of the user running applications that use the affected library to open attacker-supplied malicious files.

The AdPlug library version 2.0 is vulnerable to these issues; previous versions may also be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

The following proof-of-concept code may be used to demonstrate several of these issues by crashing the affected library:

- 解决方案

The vendor has committed fixes to their CVS repository as of July 5, 2006. Official fix packages are not currently known to be available.

Please see the referenced advisories for more information.

- 相关参考