CVE-2006-3509
CVSS7.2
发布时间 :2006-09-21 17:07:00
修订时间 :2011-03-07 21:38:46
NMCO    

[原文]Integer overflow in the API for the AirPort wireless driver on Apple Mac OS X 10.4.7 might allow physically proximate attackers to cause a denial of service (crash) or execute arbitrary code in third-party wireless software that uses the API via crafted frames.


[CNNVD]Apple Mac OS X AirPort无线驱动多个溢出漏洞(CNNVD-200609-375)

        Apple Mac OS X是苹果家族机器所使用的操作系统。
        Apple Mac OS X的AirPort无线驱动中存在多个溢出漏洞,具体如下:
        AirPort无线驱动在处理畸形帧时存在两个栈溢出。攻击者可以向无线网络中注入恶意的帧来触发这个溢出,如果打开了AirPort的话就会导致以系统权限执行任意指令。
        AirPort无线驱动在处理扫描缓存更新时存在堆溢出。攻击者可以向无线网络中注入恶意的帧来触发这个溢出,导致系统崩溃、权限提升或以系统权限执行任意指令。
        Airport无线驱动的第三方无线软件API中存在整数溢出,导致依赖于API使用的应用程序出现溢出。如果应用程序受影响的话,则攻击者可以向无线网络中注入恶意的帧来触发这个溢出,导致崩溃或以运行应用程序用户的权限执行任意指令。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.4.7Apple Mac OS X 10.4.7
cpe:/o:apple:mac_os_x_server:10.4.7Apple Mac OS X Server 10.4.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3509
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3509
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200609-375
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/563492
(UNKNOWN)  CERT-VN  VU#563492
http://www.vupen.com/english/advisories/2006/3737
(UNKNOWN)  VUPEN  ADV-2006-3737
http://lists.apple.com/archives/Security-announce/2006/Sep/msg00001.html
(UNKNOWN)  APPLE  APPLE-SA-2006-09-21
http://www.securityfocus.com/bid/20144
(UNKNOWN)  BID  20144
http://securitytracker.com/id?1016903
(UNKNOWN)  SECTRACK  1016903
http://secunia.com/advisories/22068
(UNKNOWN)  SECUNIA  22068

- 漏洞信息

Apple Mac OS X AirPort无线驱动多个溢出漏洞
高危 缓冲区溢出
2006-09-21 00:00:00 2006-09-22 00:00:00
远程  
        Apple Mac OS X是苹果家族机器所使用的操作系统。
        Apple Mac OS X的AirPort无线驱动中存在多个溢出漏洞,具体如下:
        AirPort无线驱动在处理畸形帧时存在两个栈溢出。攻击者可以向无线网络中注入恶意的帧来触发这个溢出,如果打开了AirPort的话就会导致以系统权限执行任意指令。
        AirPort无线驱动在处理扫描缓存更新时存在堆溢出。攻击者可以向无线网络中注入恶意的帧来触发这个溢出,导致系统崩溃、权限提升或以系统权限执行任意指令。
        Airport无线驱动的第三方无线软件API中存在整数溢出,导致依赖于API使用的应用程序出现溢出。如果应用程序受影响的话,则攻击者可以向无线网络中注入恶意的帧来触发这个溢出,导致崩溃或以运行应用程序用户的权限执行任意指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.apple.com/support/downloads/

- 漏洞信息

29063
Apple Airport Wireless Driver API Crafted Frame Overflow
Wireless Vector Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-09-19 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站