CVE-2006-3491
CVSS7.5
发布时间 :2006-07-10 18:05:00
修订时间 :2016-10-17 23:40:21
NMCOS    

[原文]Stack-based buffer overflow in Kaillera Server 0.86 and earlier allows remote attackers to execute arbitrary code via a long nickname.


[CNNVD]Kaillera Message 长昵称缓冲区溢出漏洞(CNNVD-200607-112)

        Kaillera Server 0.86及之前版本存在基于栈的缓冲区溢出。远程攻击者可以借助一个长的昵称,执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3491
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3491
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-112
(官方数据源) CNNVD

- 其它链接及资源

http://aluigi.altervista.org/adv/kailleraex-adv.txt
(VENDOR_ADVISORY)  MISC  http://aluigi.altervista.org/adv/kailleraex-adv.txt
http://marc.info/?l=full-disclosure&m=115220500707900&w=2
(UNKNOWN)  FULLDISC  20060706 Possible code execution in Kaillera 0.86
http://www.securityfocus.com/archive/1/archive/1/439455/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060706 Possible code execution in Kaillera 0.86
http://www.securityfocus.com/bid/18871
(UNKNOWN)  BID  18871
http://www.vupen.com/english/advisories/2006/2696
(UNKNOWN)  VUPEN  ADV-2006-2696
http://xforce.iss.net/xforce/xfdb/27680
(UNKNOWN)  XF  kaillera-nickname-bo(27680)

- 漏洞信息

Kaillera Message 长昵称缓冲区溢出漏洞
高危 缓冲区溢出
2006-07-10 00:00:00 2006-07-12 00:00:00
远程  
        Kaillera Server 0.86及之前版本存在基于栈的缓冲区溢出。远程攻击者可以借助一个长的昵称,执行任意代码。

- 公告与补丁

        暂无数据

- 漏洞信息

27041
Kaillera Server Message Nickname Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

A remote overflow exists in Kaillera Server 0.86. Kaillera Server fails to check correctly the length of nicknames in messages resulting in a stack-based buffer overflow. With a specially crafted request, an attacker can cause Deny Of Service resulting in a loss of availability.

- 时间线

2006-07-06 Unknow
2006-07-11 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Kaillera Message Buffer Overflow Vulnerability
Boundary Condition Error 18871
Yes No
2006-07-06 12:00:00 2007-07-06 07:47:00
Luigi Auriemma is credited with discovering this vulnerability.

- 受影响的程序版本

Kaillera Kaillera 0.86

- 漏洞讨论

Kaillera is prone to a buffer-overflow vulnerability because it fails to properly bounds-check messages before copying them to an insufficiently sized memory buffer.

Successful exploits can allow remote attackers to execute arbitrary machine code in the context of the user running the application.

- 漏洞利用

A proof-of-concept exploit is available.

- 解决方案

Currently we are not aware of any official vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站