发布时间 :2006-07-03 14:05:00
修订时间 :2011-03-07 21:38:23

[原文]Cross-site scripting (XSS) vulnerability in frontend/x/files/select.html in cPanel 10.8.2-CURRENT 118 and earlier allows remote attackers to inject arbitrary web script or HTML via the file parameter.

[CNNVD]Cpanel 'Select.HTML' 跨站脚本攻击漏洞(CNNVD-200607-010)

        cPanel 10.8.2-CURRENT 118 及更早版本中的 frontend/x/files/select.html 存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过file参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-2547
(UNKNOWN)  BID  18655
(UNKNOWN)  BUGTRAQ  20060626 Re: XSS in Cpanel 10
(UNKNOWN)  BUGTRAQ  20060626 XSS in Cpanel 10
(UNKNOWN)  XF  cpanel-select-xss(27403)

- 漏洞信息

Cpanel 'Select.HTML' 跨站脚本攻击漏洞
低危 跨站脚本
2006-07-03 00:00:00 2006-07-05 00:00:00
        cPanel 10.8.2-CURRENT 118 及更早版本中的 frontend/x/files/select.html 存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过file参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

cPanel select.html file Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-06-25 Unknow
2006-06-25 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Cpanel Select.HTML Cross-Site Scripting Vulnerability
Input Validation Error 18655
Yes No
2006-06-26 12:00:00 2007-03-08 03:15:00
Preth00nker is credited with the discovery of this vulnerability.

- 受影响的程序版本

cPanel cPanel 10

- 漏洞讨论

Cpanel is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

This issue affects version 10; other versions may also be vulnerable.

- 漏洞利用

This issue can be exploited through a web client.

The following proof-of-concept URI is available.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考