发布时间 :2006-06-28 19:05:00
修订时间 :2011-03-07 21:38:16

[原文]Cross-site scripting (XSS) vulnerability in the login page of the HTTP interface for the Cisco Wireless Control System (WCS) for Linux and Windows before 3.2(51) allows remote attackers to inject arbitrary web script or HTML via unspecified vectors involving a "malicious URL".

[CNNVD]Cisco无线控制系统 HTTP界面登录页面 跨站脚本漏洞(CNNVD-200606-589)

        Linux 和 Windows 上的 WCS3.2(51)之前的版本存在跨站脚本攻击漏洞。HTTP界面的登录页面无法正确的过滤用户提供数据中的恶意脚本代码,这可能导致攻击者诱骗用户访问会在用户Web浏览器中执行任意脚本代码的恶意URL。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  CISCO  20060628 Multiple Vulnerabilities in Wireless Control System
(UNKNOWN)  VUPEN  ADV-2006-2583
(UNKNOWN)  BID  18701
(UNKNOWN)  XF  cisco-wcs-http-xss(27441)

- 漏洞信息

Cisco无线控制系统 HTTP界面登录页面 跨站脚本漏洞
低危 跨站脚本
2006-06-28 00:00:00 2006-06-30 00:00:00
        Linux 和 Windows 上的 WCS3.2(51)之前的版本存在跨站脚本攻击漏洞。HTTP界面的登录页面无法正确的过滤用户提供数据中的恶意脚本代码,这可能导致攻击者诱骗用户访问会在用户Web浏览器中执行任意脚本代码的恶意URL。

- 公告与补丁


- 漏洞信息

Cisco Wireless Control System (WCS) HTTP Interface Login Page Unspecified XSS
Remote / Network Access, Wireless Vector Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Wireless Control System contains an unspecified flaw that allows a remote cross site scripting attack. This could allow a user to create a specially crafted URL referencing the HTTP interface login page that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-06-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.2(63) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Cisco Wireless Control System Multiple Security Vulnerabilities
Unknown 18701
Yes No
2006-06-28 12:00:00 2007-06-04 07:50:00
These issues were disclosed by the vendor.

- 受影响的程序版本

Cisco Wireless Control System Software 4.0
Cisco Wireless Control System Software 3.2

- 漏洞讨论

Cisco Wireless Control System is prone to multiple security vulnerabilities.

The following issues have been disclosed:

- Authorization-bypass vulnerability due to multiple hardcoded username and password pairs
- Arbitrary file access vulnerability
- Cross-site scripting vulnerability
- Information-disclosure vulnerability

An attacker can exploit these issues to retrieve potentially sensitive information, overwrite files, perform cross-site scripting attacks, and gain unauthorized access; other attacks are also possible.

- 漏洞利用

These issues do not require exploit code, but only access to the affected application.

Attackers can exploit the cross-site scripting issue by tricking a victim user into following a malicious URI.

- 解决方案

The vendor has released updates to address these issues. Please contact the vendor for details.

- 相关参考