CVE-2006-3229
CVSS4.3
发布时间 :2006-06-26 21:05:00
修订时间 :2008-09-05 17:06:34
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in Open WebMail (OWM) 2.52, and other versions released before 05/12/2006, allows remote attackers to inject arbitrary web script or HTML via the (1) To and (2) From fields in openwebmail-main.pl, and possibly (3) other unspecified vectors related to "openwebmailerror calls that need to display HTML."


[CNNVD]Open WebMail 多个脚本攻击(XSS)漏洞(CNNVD-200606-502)

        Open WebMail (OWM) 2.52及2006年5月12日之前发行的其他版本中的跨站脚本攻击(XSS)漏洞,远程攻击者通过openwebmail-main.pl中的(1) To和(2) From字段,可能还有(3)与"需要显示HTML的openwebmailerror调用"相关的其他未明向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:open_webmail:open_webmail:2.20
cpe:/a:open_webmail:open_webmail:1.71
cpe:/a:open_webmail:open_webmail:2.21
cpe:/a:open_webmail:open_webmail:1.7
cpe:/a:open_webmail:open_webmail:2.30
cpe:/a:open_webmail:open_webmail:2.52
cpe:/a:open_webmail:open_webmail:1.81
cpe:/a:open_webmail:open_webmail:1.8
cpe:/a:open_webmail:open_webmail:2.51
cpe:/a:open_webmail:open_webmail:2.41
cpe:/a:open_webmail:open_webmail:1.90
cpe:/a:open_webmail:open_webmail:2.32
cpe:/a:open_webmail:open_webmail:2.5
cpe:/a:open_webmail:open_webmail:2.31

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3229
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3229
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-502
(官方数据源) CNNVD

- 其它链接及资源

http://www.attrition.org/pipermail/vim/2006-June/000902.html
(PATCH)  VIM  20060626 Openwebmail: 2 XSS vulns not one, and some version hints
http://xforce.iss.net/xforce/xfdb/27309
(UNKNOWN)  XF  openwebmail-read-xss(27309)
http://secunia.com/advisories/20714
(UNKNOWN)  SECUNIA  20714
http://openwebmail.org/openwebmail/doc/changes.txt
(UNKNOWN)  CONFIRM  http://openwebmail.org/openwebmail/doc/changes.txt
http://openwebmail.acatysmoof.com/dev/svn/index.pl/openwebmail/diff/trunk/src/cgi-bin/openwebmail/openwebmail-main.pl?rev1=235;rev2=236
(UNKNOWN)  CONFIRM  http://openwebmail.acatysmoof.com/dev/svn/index.pl/openwebmail/diff/trunk/src/cgi-bin/openwebmail/openwebmail-main.pl?rev1=235;rev2=236

- 漏洞信息

Open WebMail 多个脚本攻击(XSS)漏洞
中危 跨站脚本
2006-06-26 00:00:00 2007-08-13 00:00:00
远程  
        Open WebMail (OWM) 2.52及2006年5月12日之前发行的其他版本中的跨站脚本攻击(XSS)漏洞,远程攻击者通过openwebmail-main.pl中的(1) To和(2) From字段,可能还有(3)与"需要显示HTML的openwebmailerror调用"相关的其他未明向量注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

31848
Open WebMail (OWM) openwebmail-main.pl Multiple XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2006-06-08 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Open WebMail Openwebmail-read.PL Cross-Site Scripting Vulnerability
Input Validation Error 18598
Yes No
2006-06-22 12:00:00 2006-06-28 07:49:00
This issue was disclosed by the vendor.

- 受影响的程序版本

Open Webmail Open Webmail 2.51
Open Webmail Open Webmail 2.41
Open Webmail Open Webmail 2.32
Open Webmail Open Webmail 2.31
Open Webmail Open Webmail 2.30
Open Webmail Open Webmail 2.21
Open Webmail Open Webmail 2.20
Open Webmail Open Webmail 2.5
Open Webmail Open Webmail 1.90
Open Webmail Open Webmail 1.81
Open Webmail Open Webmail 1.71
Open Webmail Open Webmail 1.8
Open Webmail Open Webmail 1.7
Frank McIngvale LuxMan 1.8
Frank McIngvale LuxMan 1.7.1
Frank McIngvale LuxMan 1.7
Open Webmail Open Webmail -current

- 不受影响的程序版本

Open Webmail Open Webmail -current

- 漏洞讨论

Open WebMail is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

Attackers can exploit this issue by enticing a victim user into following a malicious URI.

- 解决方案

The vendor has addressed this issue in the latest SVN repository. Contact the vendor for details on obtaining the appropriate updates.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站