CVE-2006-3176
CVSS7.5
发布时间 :2006-06-22 20:02:00
修订时间 :2011-03-07 21:38:00
NMCOS    

[原文]SQL injection vulnerability in xarancms_haupt.php in xarancms 2.0 allows remote attackers to execute arbitrary SQL commands via the id parameter.


[CNNVD]Xarancms Xarancms_haupt.PHP SQL注入漏洞(CNNVD-200606-421)

        xarancms 2.0中的xarancms_haupt.php存在SQL注入漏洞,远程攻击者可以通过id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3176
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3176
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-421
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/27198
(UNKNOWN)  XF  xarancms-id-sql-injection(27198)
http://www.vupen.com/english/advisories/2006/2420
(UNKNOWN)  VUPEN  ADV-2006-2420
http://www.securityfocus.com/bid/18520
(UNKNOWN)  BID  18520
http://www.osvdb.org/26632
(UNKNOWN)  OSVDB  26632
http://secunia.com/advisories/20739
(VENDOR_ADVISORY)  SECUNIA  20739
http://pridels0.blogspot.com/2006/06/xarancms-v20-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2006/06/xarancms-v20-vuln.html

- 漏洞信息

Xarancms Xarancms_haupt.PHP SQL注入漏洞
高危 SQL注入
2006-06-22 00:00:00 2006-07-21 00:00:00
远程  
        xarancms 2.0中的xarancms_haupt.php存在SQL注入漏洞,远程攻击者可以通过id参数执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

26632
xarancms xarancms_haupt.php id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Xarancms contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the xarancms_haupt.php script not properly sanitizing user-supplied input to the 'id' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-06-18 Unknow
2006-06-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Xarancms Xarancms_haupt.PHP SQL Injection Vulnerability
Input Validation Error 18520
Yes No
2006-06-05 12:00:00 2007-02-13 06:37:00
r0t is credited with the discovery of this vulnerability.

- 受影响的程序版本

Xaran Xarancms 2.0

- 漏洞讨论

Xarancms is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

Attackers can exploit this issue via a web client.

The following example exploit is available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站