CVE-2006-3129
CVSS4.3
发布时间 :2006-06-21 21:02:00
修订时间 :2011-03-07 21:37:55
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in index.php in NC LinkList 1.2 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) cat and (2) view parameters.


[CNNVD]NC Linklist Index.PHP 多个跨站脚本攻击漏洞(CNNVD-200606-401)

        NC LinkList 1.2及之前版本的index.php中存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1) cat和(2) view 参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3129
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3129
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-401
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2438
(UNKNOWN)  VUPEN  ADV-2006-2438
http://www.securityfocus.com/bid/18546
(UNKNOWN)  BID  18546
http://www.osvdb.org/26675
(UNKNOWN)  OSVDB  26675
http://secunia.com/advisories/20691
(UNKNOWN)  SECUNIA  20691
http://xforce.iss.net/xforce/xfdb/27248
(UNKNOWN)  XF  nclinklist-index-xss(27248)
http://pridels0.blogspot.com/2006/06/nc-linklist-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2006/06/nc-linklist-xss-vuln.html

- 漏洞信息

NC Linklist Index.PHP 多个跨站脚本攻击漏洞
中危 跨站脚本
2006-06-21 00:00:00 2006-08-17 00:00:00
远程  
        NC LinkList 1.2及之前版本的index.php中存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1) cat和(2) view 参数注入任意Web脚本或HTML。

- 公告与补丁

        厂商已经发布更新以解决此问题。更多信息,请参见引用。厂商已经发布更新以解决此问题。更多信息,请参见引用。

- 漏洞信息

26675
NC LinkList index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

NC LinkList contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'cat' and 'view' variables upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-06-19 Unknow
2006-06-19 Unknow

- 解决方案

Upgrade to version 1.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

NC Linklist Index.PHP Cross-Site Scripting Vulnerabilities
Input Validation Error 18546
Yes No
2006-06-20 12:00:00 2008-12-31 07:21:00
r0t is credited with discovering these vulnerabilities.

- 受影响的程序版本

Net Concept 24 NC LinkList 1.2
Net Concept 24 NC LinkList 1.3.1

- 不受影响的程序版本

Net Concept 24 NC LinkList 1.3.1

- 漏洞讨论

NC Linklist is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize HTML and script code from user-supplied input to several parameters before returning to the user.

An attacker could exploit these vulnerabilities to inject hostile HTML and script code into the browser session of other users of the application.

- 漏洞利用

Attackers can exploit this issue by enticing a user to follow a malicious link.

- 解决方案

The vendor released an update to address this issue. Please see the references for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站