CVE-2006-3128
CVSS4.6
发布时间 :2006-06-21 19:02:00
修订时间 :2011-03-07 21:37:55
NMCO    

[原文]choose_file.php in easy-CMS 0.1.2, when mod_mime is installed, does not restrict uploads of filenames with multiple extensions, which allows remote attackers to execute arbitrary PHP code by uploading a PHP file with a GIF file extension, then directly accessing that file in the Repositories directory.


[CNNVD]Easy CMS choose_file.php 任意文件上传漏洞(CNNVD-200606-398)

        Easy CMS是基于PHP的开放源码内容管理系统。
        Easy CMS的choose_file.php文件没有正确过滤非法的文件扩展名,允许攻击者上传任意文件。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3128
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3128
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-398
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2419
(UNKNOWN)  VUPEN  ADV-2006-2419
http://securitytracker.com/id?1016335
(UNKNOWN)  SECTRACK  1016335
http://secunia.com/advisories/20733
(VENDOR_ADVISORY)  SECUNIA  20733
http://biyosecurity.be/bugs/easycms.txt
(UNKNOWN)  MISC  http://biyosecurity.be/bugs/easycms.txt
http://xforce.iss.net/xforce/xfdb/27281
(UNKNOWN)  XF  easycms-extensions-file-upload(27281)
http://www.securityfocus.com/bid/18496
(UNKNOWN)  BID  18496
http://www.securityfocus.com/archive/1/archive/1/437705/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060618 Easy CMS 0.1.2 Php Shell Upload Vulnerabilities
http://www.osvdb.org/26633
(UNKNOWN)  OSVDB  26633

- 漏洞信息

Easy CMS choose_file.php 任意文件上传漏洞
中危 输入验证
2006-06-21 00:00:00 2006-06-22 00:00:00
远程  
        Easy CMS是基于PHP的开放源码内容管理系统。
        Easy CMS的choose_file.php文件没有正确过滤非法的文件扩展名,允许攻击者上传任意文件。

- 公告与补丁

        厂商补丁:
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.easycms.no/

- 漏洞信息

26633
easy-CMS Multiple File Extension Upload Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Easy-CMS contains a flaw that may allow a malicious user to execute remote arbitrary code. The issue is triggered when a user uploads a file with multiple extensions. It is possible that the flaw may allow the upload of a malicious script inside the web root via the choose_file.php script resulting in a loss of integrity.

- 时间线

2006-06-18 Unknow
2006-06-18 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: Move the 'Repositories' directory out of the web root.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站