CVE-2006-3120
CVSS7.5
发布时间 :2006-07-31 17:04:00
修订时间 :2011-03-07 21:37:51
NMCOPS    

[原文]Format string vulnerability in Brian Wotring Osiris before 4.2.1 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via unspecified attack vectors related to the logging functions.


[CNNVD]Brian Wotring Osiris Logging.C格式化字符串拒绝服务攻击漏洞(CNNVD-200607-511)

        Brian Wotring Osiris 4.2.1之前版本存在格式化字符串漏洞。 远程攻击者可以借助与日志功能有关的未明攻击向量,引起拒绝服务(应用程序崩溃)。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:brian_wotring:osiris:4.1.9
cpe:/a:brian_wotring:osiris:4.0.6
cpe:/a:brian_wotring:osiris:4.0.5
cpe:/a:brian_wotring:osiris:4.1.7
cpe:/a:brian_wotring:osiris:4.0.3
cpe:/a:brian_wotring:osiris:4.1.2
cpe:/a:brian_wotring:osiris:4.0.8
cpe:/a:brian_wotring:osiris:4.1.4
cpe:/a:brian_wotring:osiris:4.0.1
cpe:/a:brian_wotring:osiris:4.0.0
cpe:/a:brian_wotring:osiris:4.1.1
cpe:/a:brian_wotring:osiris:4.1.5
cpe:/a:brian_wotring:osiris:4.1
cpe:/a:brian_wotring:osiris:4.0.7
cpe:/a:brian_wotring:osiris:4.1.3
cpe:/a:brian_wotring:osiris:4.2.0
cpe:/a:brian_wotring:osiris:4.1.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3120
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3120
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200607-511
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2006/dsa-1129
(VENDOR_ADVISORY)  DEBIAN  DSA-1129
http://osiris.shmoo.com/download.html
(PATCH)  MISC  http://osiris.shmoo.com/download.html
http://www.vupen.com/english/advisories/2006/3072
(UNKNOWN)  VUPEN  ADV-2006-3072
http://osiris.shmoo.com/ChangeLog
(UNKNOWN)  CONFIRM  http://osiris.shmoo.com/ChangeLog
http://www.securityfocus.com/bid/19213
(UNKNOWN)  BID  19213
http://www.osvdb.org/27645
(UNKNOWN)  OSVDB  27645
http://secunia.com/advisories/21265
(UNKNOWN)  SECUNIA  21265
http://secunia.com/advisories/21257
(UNKNOWN)  SECUNIA  21257

- 漏洞信息

Brian Wotring Osiris Logging.C格式化字符串拒绝服务攻击漏洞
高危 格式化字符串
2006-07-31 00:00:00 2006-08-01 00:00:00
远程  
        Brian Wotring Osiris 4.2.1之前版本存在格式化字符串漏洞。 远程攻击者可以借助与日志功能有关的未明攻击向量,引起拒绝服务(应用程序崩溃)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Shmoo Osiris 4.0.6
        Debian osiris_4.0.6-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_alpha.deb
        Debian osiris_4.0.6-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_amd64.deb
        Debian osiris_4.0.6-1sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_arm.deb
        Debian osiris_4.0.6-1sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_hppa.deb
        Debian osiris_4.0.6-1sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_i386.deb
        Debian osiris_4.0.6-1sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_ia64.deb
        Debian osiris_4.0.6-1sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_m68k.deb
        Debian osiris_4.0.6-1sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_mips.deb
        Debian osiris_4.0.6-1sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_mipsel.deb
        Debian osiris_4.0.6-1sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_powerpc.deb
        Debian osiris_4.0.6-1sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_s390.deb
        Debian osiris_4.0.6-1sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sa rge1_sparc.deb
        Debian osirisd_4.0.6-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_alpha.deb
        Debian osirisd_4.0.6-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_amd64.deb
        Debian osirisd_4.0.6-1sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_arm.deb
        Debian osirisd_4.0.6-1sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_hppa.deb
        Debian osirisd_4.0.6-1sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_i386.deb
        Debian osirisd_4.0.6-1sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_ia64.deb
        Debian osirisd_4.0.6-1sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_m68k.deb
        Debian osirisd_4.0.6-1sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_mips.deb
        Debian osirisd_4.0.6-1sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_mipsel.deb
        Debian osirisd_4.0.6-1sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_powerpc.deb
        Debian osirisd_4.0.6-1sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1s arge1_sparc.deb
        Debian osirismd_4.0.6-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1 sarge1_alpha.deb
        Debian osirismd_4.0.6-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1 s

- 漏洞信息 (F48767)

Debian Linux Security Advisory 1129-1 (PacketStormID:F48767)
2006-08-03 00:00:00
Debian  debian.org
advisory,remote,denial of service,arbitrary
linux,debian
CVE-2006-3120
[点击下载]

Debian Security Advisory 1129-1 - Ulf Harnhammar and Max Vozeler from the Debian Security Audit Project have found several format string security bugs in osiris, a network-wide system integrity monitor control interface. A remote attacker could exploit them and cause a denial of service or execute arbitrary code.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1129-1                    security@debian.org
http://www.debian.org/security/                             Martin Schulze
July 28th, 2006                         http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : orisis
Vulnerability  : format string
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2006-3120

Ulf Harnhammar and Max Vozeler from the Debian Security Audit Project
have found several format string security bugs in osiris, a
network-wide system integrity monitor control interface.  A remote
attacker could exploit them and cause a denial of service or execute
arbitrary code.

For the stable distribution (sarge) these problems have been fixed in
version 4.0.6-1sarge1.

For the unstable distribution (sid) these problems have been fixed in
version 4.2.0-2.

We recommend that you upgrade your osiris packages.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given at the end of this advisory:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1.dsc
      Size/MD5 checksum:      601 f8e62dca889eac05f3c2f1cf6541bea2
    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1.diff.gz
      Size/MD5 checksum:    63328 905cddf6a6635ed215fff6f6055ad0a1
    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6.orig.tar.gz
      Size/MD5 checksum:  1882069 c23180e5e44aa4303531e0b9d9308c80

  Alpha architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_alpha.deb
      Size/MD5 checksum:   522620 c0253943d34023c1dc631c537a1ca06d
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_alpha.deb
      Size/MD5 checksum:    78458 5f28cff0c30e6cd07f372856eef76383
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_alpha.deb
      Size/MD5 checksum:   539096 6c355764d7de45c5265c6b9cddc46508

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_amd64.deb
      Size/MD5 checksum:   410616 74844c2b8a8065c3b83514e48d491181
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_amd64.deb
      Size/MD5 checksum:    64558 0a7fa1f9e50b9e0b741e632aff27d94b
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_amd64.deb
      Size/MD5 checksum:   420262 efa9f94c1800311f8681f1a22e910f9e

  ARM architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_arm.deb
      Size/MD5 checksum:   384090 474cc45ff970747ce6f12de47101f69b
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_arm.deb
      Size/MD5 checksum:    56660 4367a40e684927aea76a8e76817e6bba
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_arm.deb
      Size/MD5 checksum:   393078 0f3a51cfc73a6f44257430381408483b

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_i386.deb
      Size/MD5 checksum:   396662 94deb49a7491d638dee18d95fa60381f
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_i386.deb
      Size/MD5 checksum:    58538 740f1e83f63affb4ae27b27c2bd6428b
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_i386.deb
      Size/MD5 checksum:   408590 2cd01c3b1951b1d8abc6309bfa128ce7

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_ia64.deb
      Size/MD5 checksum:   657728 89bdbc95d1d29e26db6b51e42ad5c18c
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_ia64.deb
      Size/MD5 checksum:    86950 e9b05c215d1bcb091a5b46e262d9ca8b
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_ia64.deb
      Size/MD5 checksum:   672224 333c52a972189d3bf4675454e9ec9129

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_hppa.deb
      Size/MD5 checksum:   440916 91c3cec29a7b3996787915cb4bf593e8
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_hppa.deb
      Size/MD5 checksum:    63742 cec522bf491f0e391b1dcae6ac0e8a47
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_hppa.deb
      Size/MD5 checksum:   451814 32b8672f404ad6762490ba8f319559a5

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_m68k.deb
      Size/MD5 checksum:   326266 695f574722644d342d2b908ff0648cfb
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_m68k.deb
      Size/MD5 checksum:    50500 26d63aabe7d343a63cdda55b5deb596a
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_m68k.deb
      Size/MD5 checksum:   335394 6a860f6aa7c6e3721585343a588f3d06

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_mips.deb
      Size/MD5 checksum:   445424 aea2f31d23f86fe6e41a1611a6c14983
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_mips.deb
      Size/MD5 checksum:    68234 d48f1ce470fa97b5b5eabb7fc59a3c60
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_mips.deb
      Size/MD5 checksum:   458742 fc0f88642b7cb66315d46d44a070332d

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_mipsel.deb
      Size/MD5 checksum:   447630 c32ca383ee822bd3f5240323b5f3c048
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_mipsel.deb
      Size/MD5 checksum:    69334 d7261eba94f809df3a65074f15d0d556
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_mipsel.deb
      Size/MD5 checksum:   461632 183b4bbdf0d4e956d96101a15c5a8509

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_powerpc.deb
      Size/MD5 checksum:   406640 deaa433b54ce5816c780d40022ae3d21
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_powerpc.deb
      Size/MD5 checksum:    61124 7a6c5aec4e4bf3c765e345fbc8825916
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_powerpc.deb
      Size/MD5 checksum:   417162 1b1ccc7472836d6a45eb7cfeaa34b5aa

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_s390.deb
      Size/MD5 checksum:   394916 5b03b96a4677ef3875ff1a8e8f1f6278
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_s390.deb
      Size/MD5 checksum:    62168 ada0ea24f748b5cadacfd092307fa061
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_s390.deb
      Size/MD5 checksum:   403522 a078e447951f431b822e7e07b49d5b3b

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/o/osiris/osiris_4.0.6-1sarge1_sparc.deb
      Size/MD5 checksum:   381642 bdac8e47b6c8bed9890b3b0adc0eeea6
    http://security.debian.org/pool/updates/main/o/osiris/osirisd_4.0.6-1sarge1_sparc.deb
      Size/MD5 checksum:    56656 cd9fbcf2dff6030a09a8fb864eaeaa22
    http://security.debian.org/pool/updates/main/o/osiris/osirismd_4.0.6-1sarge1_sparc.deb
      Size/MD5 checksum:   389568 90e2dbfc27bce0a10222500f49328aa5


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEyiacW5ql+IAeqTIRAu0eAJ0cFuHiNrNqo5K0wHYgqU0uxxk4ywCeInUB
5poPkNQvIWOn256yXd4H51U=
=PAdC
-----END PGP SIGNATURE-----

    

- 漏洞信息

27645
Osiris Multiple Unspecified Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Denial of Service, Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Osiris contains a flaw that may allow a remote attacker to cause a denial of service and possibly execute arbitrary code. The issue is due to multiple format string bugs, possibly related to the logging functionality. No further details have been provided.

- 时间线

2006-07-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.0.6-1sarge1 for the Debian stable distribution (sarge). Upgrade to version 4.2.0-2 for the Debian unstable distribution (sid). Upgrade to version 4.2.1 of Osiris if using another distribution as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Osiris Logging.C Format String Vulnerability
Input Validation Error 19213
Yes No
2006-07-28 12:00:00 2006-09-19 08:46:00
Ulf Warhammer and Max Vozeler are credited with the discovery of this vulnerability.

- 受影响的程序版本

Shmoo Osiris 4.2
Shmoo Osiris 4.0.6
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Shmoo Osiris 4.2.1

- 不受影响的程序版本

Shmoo Osiris 4.2.1

- 漏洞讨论

Osiris is prone to a format-string vulnerability because it fails to properly sanitize user-supplied input before using it in a formatted-printing function.

A successful exploit could allow an attacker to execute arbitrary code or to crash the application.

Version 4.2.0 is vulnerable to this issue; other versions may also be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

The vendor has released version 4.2.1 to address this issue. Please refer to the vendor's home page for more information.


Shmoo Osiris 4.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站