CVE-2006-3115
CVSS5.1
发布时间 :2006-06-29 17:05:00
修订时间 :2008-09-05 17:06:16
NMCOP    

[原文]SQL injection vulnerability in view.php in phpRaid 3.0.4, and possibly other versions, allows remote attackers to execute arbitrary SQL commands via the raid_id parameter.


[CNNVD]phpRaid view.php SQL注入漏洞(CNNVD-200606-602)

        phpRaid 3.0.4及其他可能版本的view.php中的SQL注入漏洞。远程攻击者通过raid_id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3115
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3115
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-602
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/secunia_research/2006-47/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2006-47/advisory/
http://secunia.com/advisories/20200
(VENDOR_ADVISORY)  SECUNIA  20200
http://xforce.iss.net/xforce/xfdb/27457
(UNKNOWN)  XF  phpraid-view-sql-injection(27457)

- 漏洞信息

phpRaid view.php SQL注入漏洞
中危 SQL注入
2006-06-29 00:00:00 2006-07-03 00:00:00
远程  
        phpRaid 3.0.4及其他可能版本的view.php中的SQL注入漏洞。远程攻击者通过raid_id参数执行任意SQL命令。

- 公告与补丁

        

- 漏洞信息 (F47914)

secunia-phpRaid.txt (PacketStormID:F47914)
2006-07-02 00:00:00
Sven Krewitt  secunia.com
advisory,vulnerability,sql injection
CVE-2006-3115,CVE-2006-3116
[点击下载]

Secunia Research has discovered some vulnerabilities in phpRaid, which can be exploited by malicious people to conduct SQL injection attacks or to compromise a vulnerable system. Versions 3.0.4, 3.0.5, and 3.0.6 are affected.

====================================================================== 

                     Secunia Research 29/06/2006

      - phpRaid SQL Injection and File Inclusion Vulnerabilities -

====================================================================== 
Table of Contents

Affected Software....................................................1
Severity.............................................................2
Vendor's Description of Software.....................................3
Description of Vulnerability.........................................4
Solution.............................................................5
Time Table...........................................................6
Credits..............................................................7
References...........................................................8
About Secunia........................................................9
Verification........................................................10

====================================================================== 
1) Affected Software 

phpRaid 3.0.4, 3.0.5, 3.0.6

Other versions may also be affected.

====================================================================== 
2) Severity 

Rating: Highly critical
Impact: System access, manipulation of data
Where:  From remote

====================================================================== 
3) Vendor's Description of Software 

"phpRaid is a raid management tool for World of Warcraft"

Product Link:
http://www.spiffyjr.com

====================================================================== 
4) Description of Vulnerability

Secunia Research has discovered some vulnerabilities in phpRaid, which
can be exploited by malicious people to conduct SQL injection attacks or
to compromise a vulnerable system.

1) Input passed to the "raid_id" parameter in view.php is not properly
sanitised before being used in SQL queries. This can be exploited to
manipulate SQL queries by injecting arbitrary SQL code.

Successful exploitation requires that "magic_quotes_gpc" is disabled.

The vulnerability has been confirmed in version 3.0.4. Prior versions
may also be affected.

2) Input passed via the URL is not properly sanitised before being used
in a SQL query in the "log_hack()" function in
includes/functions_logging.php. This can be exploited to manipulate SQL
queries by injecting arbitrary SQL code.

Successful exploitation requires that "magic_quotes_gpc" is disabled.

The vulnerability has been confirmed in version 3.0.5. Other versions
may also be affected.

3) Input passed to the "phpraid_dir" parameter in multiple files is not
properly verified before being used to include files. This can be
exploited to execute arbitrary PHP code by including files from local or
external resources.

Affected files:
configuration.php
guilds.php
index.php
locations.php
login.php
lua_output.php
permissions.php
profile.php
raids.php
register.php
roster.php
view.php
logs.php (included in version 3.0.5)
users.php (included in version 3.0.5)

Successful exploitation requires that "register_globals" is enabled.

The vulnerabilities have been confirmed in version 3.0.4 and 3.0.5.
Prior versions may also be affected.

4) Input passed to the "phpraid_dir" parameter in announcements.php and
rss.php is not properly verified before being used to include files.
This can be exploited to execute arbitrary PHP code by including files
from local or external resources.

Successful exploitation requires that "register_globals" is enabled.

The vulnerabilities have been confirmed in version 3.0.6. Other versions
may also be affected.

5) Input passed to the "username" and "email" form field parameters in
register.php is not properly sanitised before being used in a SQL query.
This can be exploited to manipulate SQL queries by injecting arbitrary
SQL code.

Note: This is only vulnerable if the option "phpraid" is chosen as
authorisation type. Successful exploitation can give an attacker access
to the administration section.

Successful exploitation requires that "magic_quotes_gpc" is enabled.

The vulnerabilities have been confirmed in version 3.0.6. Other versions
may also be affected. 

====================================================================== 
5) Solution 

Vulnerability #1 has been fixed in version 3.0.5, and vulnerabilities 
#2 and #3 have been fixed in version 3.0.6.

Edit the source code to ensure that input is properly verified and
sanitised. 

====================================================================== 
6) Time Table 

26/05/2006 - Initial vendor notification.
29/05/2006 - Vendor response.
30/05/2006 - Second vendor notification.
08/06/2006 - Third vendor notification.
29/06/2006 - Public disclosure.

====================================================================== 
7) Credits 

Discovered by Sven Krewitt, Secunia Research.

====================================================================== 
8) References

The Common Vulnerabilities and Exposures (CVE) project has assigned
CVE-2006-3115 (SQL injection) and CVE-2006-3116 (file inclusion) for
the vulnerabilities. 

====================================================================== 
9) About Secunia 

Secunia collects, validates, assesses, and writes advisories regarding 
all the latest software vulnerabilities disclosed to the public. These 
advisories are gathered in a publicly available database at the 
Secunia website:

http://secunia.com/

Secunia offers services to our customers enabling them to receive all 
relevant vulnerability information to their specific system 
configuration. 

Secunia offers a FREE mailing list called Secunia Security Advisories: 

http://secunia.com/secunia_security_advisories/

====================================================================== 
10) Verification 

Please verify this advisory by visiting the Secunia website:
http://secunia.com/secunia_research/2006-47/

Complete list of vulnerability reports published by Secunia Research:
http://secunia.com/secunia_research/

======================================================================




    

- 漏洞信息

26886
phpRaid view.php raid_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-06-29 2006-05-26
Unknow Unknow

- 解决方案

Upgrade to version 3.0.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站