CVE-2006-3109
CVSS4.3
发布时间 :2006-06-20 21:02:00
修订时间 :2011-03-07 21:37:50
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Cisco CallManager 3.3 before 3.3(5)SR3, 4.1 before 4.1(3)SR4, 4.2 before 4.2(3), and 4.3 before 4.3(1), allows remote attackers to inject arbitrary web script or HTML via the (1) pattern parameter in ccmadmin/phonelist.asp and (2) arbitrary parameters in ccmuser/logon.asp, aka bugid CSCsb68657.


[CNNVD]Cisco CallManager 多个跨站脚本攻击漏洞(CNNVD-200606-379)

        Cisco CallManager 3.3 3.3(5)SR3之前的3.3 版本, 4.1(3)SR4之前的4.1 版本, 4.2(3)之前的4.2版本,以及4.3(1)之前的4.3版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1)ccmadmin/phonelist.asp中的pattern参数和(2)ccmuser/logon.asp中的任意参数,注入任意Web脚本或HTML,又称CSCsb68657。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/h:cisco:call_manager:4.2%281%29Cisco Call Manager 4.2.1
cpe:/h:cisco:call_manager:4.1%283%29sr2Cisco Call Manager 4.1.3 SR2
cpe:/h:cisco:call_manager:4.1%283%29es07Cisco Call Manager 4.1.3 ES07
cpe:/h:cisco:call_manager:3.3%285%29Cisco Call Manager 3.3.5
cpe:/h:cisco:call_manager:4.1Cisco Call Manager 4.1
cpe:/h:cisco:call_manager:4.1%283%29sr3Cisco Call Manager 4.1.3 SR3
cpe:/h:cisco:call_manager:3.3%285%29es30Cisco Call Manager 3.3.5 ES30
cpe:/h:cisco:call_manager:4.1%282%29es33Cisco Call Manager 4.1.2 ES33
cpe:/h:cisco:call_manager:4.2%282%29Cisco Call Manager 4.2.2
cpe:/h:cisco:call_manager:4.1%282%29es55Cisco Call Manager 4.1.2 ES55
cpe:/h:cisco:call_manager:4.3%281%29Cisco Call Manager 4.3.1
cpe:/h:cisco:call_manager:4.2Cisco Call Manager 4.2
cpe:/h:cisco:call_manager:3.3%283%29es61Cisco Call Manager 3.3.3 ES61
cpe:/h:cisco:call_manager:4.1%283%29sr1Cisco Call Manager 4.1.3 SR1
cpe:/h:cisco:call_manager:4.3Cisco Call Manager 4.3
cpe:/h:cisco:call_manager:3.3Cisco Call Manager 3.3
cpe:/h:cisco:call_manager:4.1%283%29es32Cisco Call Manager 4.1.3 ES32
cpe:/h:cisco:call_manager:3.3%284%29es25Cisco Call Manager 3.3.4 ES25
cpe:/h:cisco:call_manager:3.3%283%29Cisco Call Manager 3.3.3
cpe:/h:cisco:call_manager:3.3%285%29sr2Cisco Call Manager 3.3.5 SR2
cpe:/h:cisco:call_manager:3.3%285%29sr1Cisco Call Manager 3.3.5 SR1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3109
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3109
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-379
(官方数据源) CNNVD

- 其它链接及资源

http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_security_response09186a00806c0846.html
(PATCH)  CISCO  20060619 Cisco Response to: Input Validation/Output Encoding Vulnerabilities in Cisco CallManager Allow Script Injection Attacks
http://securitytracker.com/id?1016328
(PATCH)  SECTRACK  1016328
http://www.vupen.com/english/advisories/2006/2443
(UNKNOWN)  VUPEN  ADV-2006-2443
http://www.securityfocus.com/bid/18504
(UNKNOWN)  BID  18504
http://www.securityfocus.com/archive/1/archive/1/437757/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060619 Input Validation/Output Encoding Vulnerabilities in Cisco CallManager Allow Script Injection Attacks
http://www.fishnetsecurity.com/csirt/disclosure/cisco/Cisco+CallManager+XSS+Advisory.htm
(UNKNOWN)  MISC  http://www.fishnetsecurity.com/csirt/disclosure/cisco/Cisco+CallManager+XSS+Advisory.htm
http://lists.grok.org.uk/pipermail/full-disclosure/2006-June/047015.html
(UNKNOWN)  FULLDISC  20060619 Input Validation/Output Encoding Vulnerabilities in Cisco CallManager Allow Script Injection Attacks
http://xforce.iss.net/xforce/xfdb/27225
(UNKNOWN)  XF  cisco-callmanager-web-xss(27225)
http://www.osvdb.org/26652
(UNKNOWN)  OSVDB  26652
http://www.osvdb.org/26651
(UNKNOWN)  OSVDB  26651
http://securityreason.com/securityalert/1114
(UNKNOWN)  SREASON  1114
http://secunia.com/advisories/20735
(UNKNOWN)  SECUNIA  20735
http://lists.grok.org.uk/pipermail/full-disclosure/2006-June/047019.html
(UNKNOWN)  FULLDISC  20060620 Re: Input Validation/Output Encoding Vulnerabilities in Cisco CallManager Allow Script Injection Attacks

- 漏洞信息

Cisco CallManager 多个跨站脚本攻击漏洞
中危 跨站脚本
2006-06-20 00:00:00 2006-06-22 00:00:00
远程  
        Cisco CallManager 3.3 3.3(5)SR3之前的3.3 版本, 4.1(3)SR4之前的4.1 版本, 4.2(3)之前的4.2版本,以及4.3(1)之前的4.3版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1)ccmadmin/phonelist.asp中的pattern参数和(2)ccmuser/logon.asp中的任意参数,注入任意Web脚本或HTML,又称CSCsb68657。

- 公告与补丁

        Cisco已经发布公告以解决此问题。据称修复程序即将发布。更多信息,请参见引用的公告。

- 漏洞信息

26651
Cisco CallManager Web Interface ccmadmin/phonelist.asp pattern Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Cisco CallManager contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'pattern' variable upon submission to the ccmadmin/phonelist.asp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-06-19 Unknow
2006-06-19 Unknow

- 解决方案

Upgrade to version 3.3(5)SR3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站