CVE-2006-3102
CVSS5.1
发布时间 :2006-06-20 21:02:00
修订时间 :2011-03-07 21:37:50
NMCO    

[原文]Race condition in articles/BitArticle.php in Bitweaver 1.3, when run on Apache with the mod_mime extension, allows remote attackers to execute arbitrary PHP code by uploading arbitrary files with double extensions, which are stored for a small period of time under the webroot in the temp/articles directory.


[CNNVD]Bitweaver articles/BitArticle.php 任意PHP代码执行漏洞(CNNVD-200606-383)

        Bitweaver 1.3中的articles/BitArticle.php存在竞态条件。在带mod_mime扩展名的Apache上运行时,远程攻击者可以通过上传可在temp/articles目录中的webroot下短时间储存的,带有双重扩展名的任意文件,执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3102
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3102
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-383
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/20695
(VENDOR_ADVISORY)  SECUNIA  20695
http://www.vupen.com/english/advisories/2006/2405
(UNKNOWN)  VUPEN  ADV-2006-2405
http://www.securityfocus.com/archive/1/archive/1/437491/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060617 bitweaver <= v1.3 multiple vulnerabilities
http://retrogod.altervista.org/bitweaver_13_xpl.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/bitweaver_13_xpl.html
http://xforce.iss.net/xforce/xfdb/27215
(UNKNOWN)  XF  bitweaver-modmime-file-upload(27215)
http://www.osvdb.org/26587
(UNKNOWN)  OSVDB  26587
http://www.milw0rm.com/exploits/1918
(UNKNOWN)  MILW0RM  1918
http://www.bitweaver.org/articles/45
(UNKNOWN)  CONFIRM  http://www.bitweaver.org/articles/45
http://sourceforge.net/project/shownotes.php?release_id=336854&group_id=141358
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=336854&group_id=141358
http://securityreason.com/securityalert/1115
(UNKNOWN)  SREASON  1115

- 漏洞信息

Bitweaver articles/BitArticle.php 任意PHP代码执行漏洞
中危 未知
2006-06-20 00:00:00 2006-08-17 00:00:00
远程  
        Bitweaver 1.3中的articles/BitArticle.php存在竞态条件。在带mod_mime扩展名的Apache上运行时,远程攻击者可以通过上传可在temp/articles目录中的webroot下短时间储存的,带有双重扩展名的任意文件,执行任意PHP代码。

- 公告与补丁

        

- 漏洞信息

26587
bitweaver articles/edit.php Arbitrary File Upload
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bitweaver contains a flaw that may allow a malicious user to execute arbitrary PHP code. The issue is triggered due to an error in articles/BitArticle.php when a user uploads files via articles/edit.php with multiple file name extensions and executes them in the /temp/articles directory. It is possible that the flaw may allow remote code execution resulting in a loss of integrity.

- 时间线

2006-06-16 Unknow
2006-06-16 Unknow

- 解决方案

Upgrade to version 1.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站