CVE-2006-3063
CVSS2.6
发布时间 :2006-06-19 06:02:00
修订时间 :2011-03-07 21:37:33
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in myPHP Guestbook 1.x through 2.0.0-r1 and before 2.0.1 RC5 allow remote attackers to inject arbitrary web script or HTML via the (1) comment, (2) email, (3) homepage, (4) id, (5) name, and (6) text parameters in (a) index.php, the (7) comment, (8) email, (9) homepage, (10) number, (11) name, and (12) text parameters in (b) admin/guestbook.php, and the (13) email, (14) homepage, (15) icq, (16) name, and (17) text parameters in (c) admin/edit.php.


[CNNVD]myPHP Guestbook 多个跨站脚本攻击(XSS)漏洞(CNNVD-200606-356)

        myPHP Guestbook 1.x 到 2.0.0-r1以及2.0.1 RC5之前版本存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(a) index.php中的(1) comment, (2) email, (3) homepage, (4) id, (5) name和(6) text参数, (b) admin/guestbook.php中的 (7) comment, (8) email, (9) homepage, (10) number, (11) name和(12) text参数, 以及(c) admin/edit.php中的(13) email, (14) homepage, (15) icq, (16) name和(17) text参数,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0-r1
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.1_rc3
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.1_rc4
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_rc4
cpe:/a:myphp_guestbook:myphp_guestbook:1.8
cpe:/a:myphp_guestbook:myphp_guestbook:1.8.3
cpe:/a:myphp_guestbook:myphp_guestbook:1.9
cpe:/a:myphp_guestbook:myphp_guestbook:1.0
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.1_beta
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.1_rc1
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_rc2
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_rc3
cpe:/a:myphp_guestbook:myphp_guestbook:1.9.2
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.1_rc2
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_beta
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_rc1
cpe:/a:myphp_guestbook:myphp_guestbook:2.0.0_alpha

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3063
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3063
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-356
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2480
(UNKNOWN)  VUPEN  ADV-2006-2480
http://www.networkarea.ch/forum/topic.php?id=4&s=9106beea248ecd1a552439168ada227e
(UNKNOWN)  CONFIRM  http://www.networkarea.ch/forum/topic.php?id=4&s=9106beea248ecd1a552439168ada227e
http://xforce.iss.net/xforce/xfdb/27293
(UNKNOWN)  XF  myphp-guestbook-multiple-scripts-xss(27293)
http://www.securityfocus.com/bid/18582
(UNKNOWN)  BID  18582
http://secunia.com/advisories/20764
(UNKNOWN)  SECUNIA  20764

- 漏洞信息

myPHP Guestbook 多个跨站脚本攻击(XSS)漏洞
低危 跨站脚本
2006-06-19 00:00:00 2006-06-19 00:00:00
远程  
        myPHP Guestbook 1.x 到 2.0.0-r1以及2.0.1 RC5之前版本存在多个跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(a) index.php中的(1) comment, (2) email, (3) homepage, (4) id, (5) name和(6) text参数, (b) admin/guestbook.php中的 (7) comment, (8) email, (9) homepage, (10) number, (11) name和(12) text参数, 以及(c) admin/edit.php中的(13) email, (14) homepage, (15) icq, (16) name和(17) text参数,注入任意Web脚本或HTML。

- 公告与补丁

        厂商已就这些问题提供了补丁。 管理员应升级到 2.0.2或更高版本。IBM已发布多个公告来解决这些问题。 更多信息,请参见引用的公告。

- 漏洞信息

26758
myPHP Guestbook index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-01 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MyPHP Guestbook Multiple Cross Site Scripting Vulnerabilities
Input Validation Error 18582
Yes No
2006-06-22 12:00:00 2006-06-22 07:50:00
The vendor reported these issues.

- 受影响的程序版本

myPHP Guestbook myPHP Guestbook 2.0
myPHP Guestbook myPHP Guestbook 2.0.1
myPHP Guestbook myPHP Guestbook 2.0.2

- 不受影响的程序版本

myPHP Guestbook myPHP Guestbook 2.0.2

- 漏洞讨论

myPHP Guestbook is a web-based guestbook application developed in PHP. It is prone to multiple cross-site scripting vulnerabilities.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

These issues can be exploited through a web client.

- 解决方案

A vendor-supplied patch for these issues is available. Administrators should upgrade to version 2.0.2 or greater.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站