发布时间 :2006-06-16 06:02:00
修订时间 :2008-09-05 17:06:08

[原文]Unspecified vulnerability in NetworkManager daemon for DHCP (dhcdbd) allows remote attackers to cause a denial of service (crash) via certain invalid DHCP responses that trigger memory corruption.

[CNNVD]DHCP NetworkManager daemon 未明漏洞(CNNVD-200606-338)

        DHCP (dhcdbd)的NetworkManager daemon存在未明漏洞。远程攻击者可以借助可触发内存破坏的某些无效的DHCP响应,引起拒绝服务(崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  18459
(UNKNOWN)  XF  dhcdbd-dhcp-response-dos(27291)

- 漏洞信息

DHCP NetworkManager daemon 未明漏洞
中危 其他
2006-06-16 00:00:00 2006-06-16 00:00:00
        DHCP (dhcdbd)的NetworkManager daemon存在未明漏洞。远程攻击者可以借助可触发内存破坏的某些无效的DHCP响应,引起拒绝服务(崩溃)。

- 公告与补丁

        GNOME dhcdbd 1.12
        GNOME dhcdbd-1.14.tar.gz
        GNOME dhcdbd 1.10
        GNOME dhcdbd-1.14.tar.gz
        Ubuntu dhcdbd_1.10-0ubuntu11.1_amd64.deb
        Ubuntu 6.06 LTS tu11.1_amd64.deb
        Ubuntu dhcdbd_1.10-0ubuntu11.1_amd64.deb
        Ubuntu 6.06 LTS tu11.1_i386.deb
        Ubuntu dhcdbd_1.10-0ubuntu11.1_powerpc.deb
        Ubuntu 6.06 LTS tu11.1_powerpc.deb

- 漏洞信息

dhcdbd NetworkManager DHCP Message Handling Memory Corruption DoS
Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-06-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.14 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

DHCDBD Remote Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 18459
Yes No
2006-06-15 12:00:00 2006-06-30 09:54:00
Discovery is credited to Florian Hackenberger<>.

- 受影响的程序版本

Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Personal 10.0 OSS
GNOME dhcdbd 1.12
GNOME dhcdbd 1.10
GNOME dhcdbd 1.14

- 不受影响的程序版本

GNOME dhcdbd 1.14

- 漏洞讨论

DHCDBD is prone to a remote denial-of-service vulnerability.

The issue presents itself when the application handles malformed data and accesses out-of-bounds memory.

DHCDBD 1.10 and 1.12 are vulnerable to this issue; other versions may also be affected.

- 漏洞利用

Attackers use readily available network utilities to exploit this issue.

- 解决方案

The vendor has released version 1.14 to address this issue.

Please see the referenced third-party vendor advisories for information on obtaining and applying fixes.

GNOME dhcdbd 1.12

GNOME dhcdbd 1.10

- 相关参考