CVE-2006-3047
CVSS4.3
发布时间 :2006-06-16 06:02:00
修订时间 :2012-10-24 00:00:00
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in TikiWiki 1.9.3.2 and possibly earlier versions allows remote attackers to inject arbitrary web script or HTML via unknown attack vectors.


[CNNVD]TikiWiki 跨站脚本攻击(XSS)漏洞(CNNVD-200606-329)

        TikiWiki 1.9.3.2及可能的更早版本中存在跨站脚本攻击(XSS)漏洞。远程攻击者可通过未知攻击向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.2Tiki Tikiwiki CMS/Groupware 1.9.2
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.0:rc1Tiki Tikiwiki CMS/Groupware 1.9.0 release candidate 1
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.0:rc3Tiki Tikiwiki CMS/Groupware 1.9.0 release candidate 3
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.0Tiki Tikiwiki CMS/Groupware 1.9.0
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.0:rc2Tiki Tikiwiki CMS/Groupware 1.9.0 release candidate 2
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.1Tiki Tikiwiki CMS/Groupware 1.9.1
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.3.1Tiki Tikiwiki CMS/Groupware 1.9.3.1
cpe:/a:tiki:tikiwiki_cms%2Fgroupware:1.9.3Tiki Tikiwiki CMS/Groupware 1.9.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3047
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3047
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-329
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/437017/100/0/threaded
(PATCH)  BUGTRAQ  20060613 TikiWiki Sql injection & XSS Vulnerabilities
http://sourceforge.net/project/shownotes.php?group_id=64258&release_id=423840
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=64258&release_id=423840
http://xforce.iss.net/xforce/xfdb/27145
(UNKNOWN)  XF  tikiwiki-script-errors-xss(27145)
http://www.vupen.com/english/advisories/2006/2349
(UNKNOWN)  VUPEN  ADV-2006-2349
http://www.securityfocus.com/bid/18421
(UNKNOWN)  BID  18421
http://www.gentoo.org/security/en/glsa/glsa-200606-29.xml
(UNKNOWN)  GENTOO  GLSA-200606-29
http://securityreason.com/securityalert/1102
(UNKNOWN)  SREASON  1102
http://secunia.com/advisories/20850
(VENDOR_ADVISORY)  SECUNIA  20850
http://secunia.com/advisories/20648
(VENDOR_ADVISORY)  SECUNIA  20648

- 漏洞信息

TikiWiki 跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-06-16 00:00:00 2007-08-13 00:00:00
远程  
        TikiWiki 1.9.3.2及可能的更早版本中存在跨站脚本攻击(XSS)漏洞。远程攻击者可通过未知攻击向量注入任意Web脚本或HTML。

- 公告与补丁

        厂商已经发布了1.9.4 版本以解决这些问题;请参阅参考部分了解更多信息和厂商公告。
        TikiWiki Project TikiWiki 1.9.3 1
        TikiWiki Project tikiwiki-1.9.4.tar.gz
        http://prdownloads.sourceforge.net/tikiwiki/tikiwiki-1.9.4.tar.gz
        TikiWiki Project TikiWiki 1.9.3 2
        TikiWiki Project tikiwiki-1.9.4.tar.gz
        http://prdownloads.sourceforge.net/tikiwiki/tikiwiki-1.9.4.tar.gz

- 漏洞信息

26455
TikiWiki Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-06-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.9.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

TikiWiki Multiple Input Validation Vulnerabilities
Input Validation Error 18421
Yes No
2006-06-14 12:00:00 2006-06-29 05:59:00
bug@securitynews.ir is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

TikiWiki Project TikiWiki 1.9.3 1
TikiWiki Project TikiWiki 1.9.3.2
Gentoo Linux
TikiWiki Project TikiWiki 1.9.4

- 不受影响的程序版本

TikiWiki Project TikiWiki 1.9.4

- 漏洞讨论

TikiWiki is prone to multiple input-validation vulnerabilities. The issues include cross-site scripting and SQL-injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

A successful exploit of these vulnerabilities could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, or even exploit vulnerabilities in the underlying database implementation. Other attacks are also possible.

- 漏洞利用

These issues can be exploited through a web client.

- 解决方案

The vendor has released version 1.9.4 to address these issues; please see the reference section for details and vendor advisories.


TikiWiki Project TikiWiki 1.9.3.2

TikiWiki Project TikiWiki 1.9.3 1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站