CVE-2006-3012
CVSS7.5
发布时间 :2006-06-19 06:02:00
修订时间 :2011-03-07 21:37:28
NMCOP    

[原文]SQL injection vulnerability in phpBannerExchange before 2.0 Update 6 allows remote attackers to execute arbitrary SQL commands via the (1) login parameter in (a) client/stats.php and (b) admin/stats.php, or the (2) pass parameter in client/stats.php.


[CNNVD]phpBannerExchange 多个SQL注入漏洞(CNNVD-200606-362)

        phpBannerExchange 2.0 Update 6之前版本存在SQL注入漏洞。远程攻击者可以借助(a) client/stats.php和(b)admin/stats.php中的(1)login参数,或client/stats.php中的(2)pass参数,执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:eschew.net:phpbannerexchange:2.0_update_3
cpe:/a:eschew.net:phpbannerexchange:2.0
cpe:/a:eschew.net:phpbannerexchange:2.0_update_2
cpe:/a:eschew.net:phpbannerexchange:2.0_update_1
cpe:/a:eschew.net:phpbannerexchange:2.0_update_4
cpe:/a:eschew.net:phpbannerexchange:2.0_update_5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3012
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-3012
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-362
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/18448
(PATCH)  BID  18448
http://www.securityfocus.com/archive/1/archive/1/437290/100/0/threaded
(PATCH)  BUGTRAQ  20060615 Advisory: Authentication bypass in phpBannerExchange
http://www.vupen.com/english/advisories/2006/2402
(UNKNOWN)  VUPEN  ADV-2006-2402
http://www.redteam-pentesting.de/advisories/rt-sa-2006-004.txt
(VENDOR_ADVISORY)  MISC  http://www.redteam-pentesting.de/advisories/rt-sa-2006-004.txt
http://www.eschew.net/scripts/phpbe/2.0/releasenotes.php
(UNKNOWN)  CONFIRM  http://www.eschew.net/scripts/phpbe/2.0/releasenotes.php
http://xforce.iss.net/xforce/xfdb/27195
(UNKNOWN)  XF  phpbannerexchange-stats-sql-injection(27195)
http://www.osvdb.org/26510
(UNKNOWN)  OSVDB  26510
http://lists.grok.org.uk/pipermail/full-disclosure/2006-June/046954.html
(UNKNOWN)  FULLDISC  20060615 Advisory: Authentication bypass in phpBannerExchange

- 漏洞信息

phpBannerExchange 多个SQL注入漏洞
高危 SQL注入
2006-06-19 00:00:00 2006-06-19 00:00:00
远程  
        phpBannerExchange 2.0 Update 6之前版本存在SQL注入漏洞。远程攻击者可以借助(a) client/stats.php和(b)admin/stats.php中的(1)login参数,或client/stats.php中的(2)pass参数,执行任意SQL命令。

- 公告与补丁

        厂商已经发布2.0.RC5 版来解决这些问题。详见参考部分。
        http://www.eschew.net/scripts/download.php?id=12
        

- 漏洞信息 (F47616)

rt-sa-2006-004.txt (PacketStormID:F47616)
2006-06-25 00:00:00
RedTeam Pentesting  redteam-pentesting.de
exploit,sql injection
CVE-2006-3012
[点击下载]

RedTeam has identified two SQL injections in phpBannerExchange versions 2.0 RC5 and below. It is possible to bypass user authentication with them.

Advisory: Authentication bypass in phpBannerExchange

RedTeam identified two SQL injections in phpBannerExchange. It is
possible to bypass user authentication with them.


Details
=======

Product: phpBannerExchange
Affected Versions: All versions up to phpBannerExchange 2.0 RC5
Fixed Versions: 2.0 RC6
Vulnerability Type: SQL injections
Security-Risk: medium
Vendor-URL: http://www.eschew.net/scripts/phpbe/2.0/
Vendor-Status: informed, fixed version released
Advisory-URL: http://www.redteam-pentesting.de/advisories/rt-sa-2006-004.txt
Advisory-Status: public
CVE: CVE-2006-3012
CVE-URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3012


Introduction
============

From the vendor's homepage:
phpBannerExchange is a PHP/mySQL script that allows virtually anyone
with minimal knowledge of PHP, mySQL and web hosting to run their own
banner exchange.


More Details
============

In file "client/stats.php" the variables $login and $pass are not
sanitized at all.

[...]
42    $login=$_REQUEST['login'];
43    $pass=$_REQUEST['pass'];
[...]

If plaintext password are allowed ($usemd5 != "Y"), following SQL query
is used:

[...]
59    $result = mysql_query("select * from banneruser where
                             login='$login' AND pass='$pass'");
[...]

By passing the special character "'" it is possible to alter the SQL
query and bypass authentication.

A similar vulnerability exists in "admin/stats.php":

[...]
49    $login=$_SESSION['login'];
50    $pass=$_SESSION['pass'];
[...]
54    $result = mysql_query("select * from banneradmin where 
                             adminuser='$login' 
                             AND adminpass='$encpw'");
[...]


Proof of Concept
================

User login or administrator login:
Use "'or''='" for both login name and password. You will be
authenticated as the first user/admin in the database.


Workaround
==========

Use PHP Magic Quotes.


Fix
===

Upgrade to version 2.0 RC6


Security Risk
=============

The security risk is high because an attacker could gain access to an
administrator account and view and alter the database and hereby
compromise the whole application.


History
=======

2006-06-09 Discovery of the problem
2006-06-10 Vendor is informed
2006-06-12 Vendor releases fixed version

References
==========

[1] http://www.eschew.net/scripts/phpbe/2.0/


RedTeam
=======

RedTeam Pentesting is offering individual penetration tests, short
pentests, performed by a team of specialised IT-security experts.
Hereby, security weaknesses in company networks are uncovered and can be
fixed immediately.

As there are only few experts in this field, RedTeam wants to share its
knowledge and enhance the public knowledge with research in security
related areas. The results are made available as public security
advisories.

More information about RedTeam can be found at
http://www.redteam-pentesting.de.

-- 
RedTeam Pentesting            Tel.: +49-(0)241-963 1300
Dennewartstr. 25-27           Fax : +49-(0)241-963 1304
52068 Aachen           http://www.redteam-pentesting.de
    

- 漏洞信息

26510
phpBannerExchange stats.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PhpBannerExchange contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the stats.php script not properly sanitizing user-supplied input to the 'login' and 'pass' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-06-15 2006-06-09
2006-06-09 Unknow

- 解决方案

Upgrade to version 2.0 RC6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站