CVE-2006-2877
CVSS7.5
发布时间 :2006-06-06 20:02:00
修订时间 :2008-09-05 17:05:40
NMCO    

[原文]PHP remote file inclusion vulnerability in Bookmark4U 2.0.0 and earlier allows remote attackers to include arbitrary PHP files via the include_prefix parameter in (1) inc/dbase.php, (2) inc/config.php, (3) inc/common.php, and (4) inc/function.php. NOTE: it has been reported that the inc directory is protected by a .htaccess file, so this issue only applies in certain environments or configurations.


[CNNVD]Bookmark4U 多个远程文件包含漏洞(CNNVD-200606-140)

        Bookmark4U 2.0.0及更早版本存在PHP远程文件包含漏洞,远程攻击者可通过在(1)inc/dbase.php,(2)inc/config.php,(3)inc/common.php和(4)inc/function.php内的include_prefix参数来包含任意PHP文件。注意:据报告inc目录受.htaccess文件保护,因为此问题只在特定环境或配置中出现。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2877
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2877
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-140
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/26933
(UNKNOWN)  XF  bookmark4u-includeprefix-file-include(26933)
http://www.securityfocus.com/bid/18281
(UNKNOWN)  BID  18281
http://www.securityfocus.com/archive/1/archive/1/436027/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060605 Re: Bookmark4U Remote File Include
http://www.securityfocus.com/archive/1/archive/1/435964/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060604 Bookmark4U Remote File Include
http://www.osvdb.org/26602
(UNKNOWN)  OSVDB  26602
http://www.osvdb.org/26601
(UNKNOWN)  OSVDB  26601
http://www.osvdb.org/26600
(UNKNOWN)  OSVDB  26600
http://www.osvdb.org/26599
(UNKNOWN)  OSVDB  26599
http://securitytracker.com/id?1016224
(UNKNOWN)  SECTRACK  1016224
http://securityreason.com/securityalert/1058
(UNKNOWN)  SREASON  1058
http://secunia.com/advisories/19758
(UNKNOWN)  SECUNIA  19758

- 漏洞信息

Bookmark4U 多个远程文件包含漏洞
高危 输入验证
2006-06-06 00:00:00 2006-10-30 00:00:00
远程  
        Bookmark4U 2.0.0及更早版本存在PHP远程文件包含漏洞,远程攻击者可通过在(1)inc/dbase.php,(2)inc/config.php,(3)inc/common.php和(4)inc/function.php内的include_prefix参数来包含任意PHP文件。注意:据报告inc目录受.htaccess文件保护,因为此问题只在特定环境或配置中出现。

- 公告与补丁

        暂无数据

- 漏洞信息

26599
Bookmark4U inc/dbase.php env[include_prefix] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bookmark4U contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to inc/dbase.php not properly sanitizing user input supplied to the 'env[include_prefix]' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-06-04 Unknow
2006-06-04 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站