发布时间 :2006-06-06 16:06:00
修订时间 :2011-03-07 21:37:08

[原文]SQL injection vulnerability in content.php in abarcar Realty Portal 5.1.5 allows remote attackers to execute arbitrary SQL commands via the cat parameter.

[CNNVD]Abarcar Realty Portal Content.PHP SQL注入漏洞(CNNVD-200606-120)

        abarcar Realty Portal 5.1.5中content.php存在SQL注入漏洞,远程攻击者可以通过cat参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  abarcar-realty-portal-content-sql-injection(26993)
(UNKNOWN)  VUPEN  ADV-2006-2194
(UNKNOWN)  BID  18218

- 漏洞信息

Abarcar Realty Portal Content.PHP SQL注入漏洞
高危 SQL注入
2006-06-06 00:00:00 2006-10-30 00:00:00
        abarcar Realty Portal 5.1.5中content.php存在SQL注入漏洞,远程攻击者可以通过cat参数执行任意SQL命令。

- 公告与补丁


- 漏洞信息

abarcar Realty Portal content.php cat Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

abarcar Realty Portal contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to content.php not properly sanitizing user-supplied input to the 'cat' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-06-08 Unknow
2006-06-08 Unknow

- 解决方案

Upgrade to version 7.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Abarcar Realty Portal Content.PHP SQL Injection Vulnerability
Input Validation Error 18218
Yes No
2006-06-01 12:00:00 2007-02-20 11:36:00
SpC-x credited with the discovery of this vulnerability.

- 受影响的程序版本

abarcar Realty Portal Realty Portal 5.1.5
abarcar Realty Portal System 7.2
abarcar Realty Portal System 7.1
abarcar Realty Portal System 7.0

- 不受影响的程序版本

abarcar Realty Portal System 7.2
abarcar Realty Portal System 7.1
abarcar Realty Portal System 7.0

- 漏洞讨论

Abarcar Realty Portal is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

This issue can be exploited through a web client.

The following proof-of-concept URI is available:

- 解决方案

This issue has been addressed by the vendor as of version 7.0. Please contact the vendor for information on how to obtain an updated version.

- 相关参考