CVE-2006-2851
CVSS4.3
发布时间 :2006-06-06 16:06:00
修订时间 :2011-03-07 21:37:08
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in index.php in dotProject 2.0.2 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified parameters, which are not properly handled when the client is using Internet Explorer.


[CNNVD]dotProject index.php 跨站脚本攻击(XSS)漏洞(CNNVD-200606-125)

        dotProject 2.0.2及更早版本中的index.php存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过未明参数(当客户端使用Internet Explorer时系统未正确处理这些参数)来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dotproject:dotproject:2.0
cpe:/a:dotproject:dotproject:2.0.2
cpe:/a:dotproject:dotproject:2.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2851
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2851
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-125
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=422371
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=422371
http://www.vupen.com/english/advisories/2006/2124
(UNKNOWN)  VUPEN  ADV-2006-2124
http://www.securityfocus.com/bid/18275
(UNKNOWN)  BID  18275
http://secunia.com/advisories/20418
(VENDOR_ADVISORY)  SECUNIA  20418
http://jvn.jp/jp/JVN%2397636431/index.html
(UNKNOWN)  JVN  JVN#97636431
http://xforce.iss.net/xforce/xfdb/26904
(UNKNOWN)  XF  dotproject-xss(26904)

- 漏洞信息

dotProject index.php 跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-06-06 00:00:00 2006-11-02 00:00:00
远程  
        dotProject 2.0.2及更早版本中的index.php存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过未明参数(当客户端使用Internet Explorer时系统未正确处理这些参数)来注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://prdownloads.sourceforge.net/dotproject/dotproject-2.0.3.tar.gz

- 漏洞信息

25975
dotProject Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

dotProject contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified input upon submission to a script, possibly includes/version.php and/or install/do_install_db.php. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-06-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站